summaryrefslogtreecommitdiff
path: root/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild')
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild b/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
new file mode 100644
index 000000000000..634f0884bc80
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ net-dialup/ppp
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}/systemd_substitute_bin_and_sysconfig_dirs.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}