summaryrefslogtreecommitdiff
path: root/net-vpn/mullvad-netns/mullvad-netns-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-vpn/mullvad-netns/mullvad-netns-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-vpn/mullvad-netns/mullvad-netns-9999.ebuild')
-rw-r--r--net-vpn/mullvad-netns/mullvad-netns-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-vpn/mullvad-netns/mullvad-netns-9999.ebuild b/net-vpn/mullvad-netns/mullvad-netns-9999.ebuild
new file mode 100644
index 000000000000..caf10671bae6
--- /dev/null
+++ b/net-vpn/mullvad-netns/mullvad-netns-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/chutz/mullvad-netns.git"
+else
+ SRC_URI=""
+ die
+fi
+
+DESCRIPTION="Script to run a command within a Mullvad network namespace"
+HOMEPAGE="https://github.com/chutz/mullvad-netns"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ app-misc/jq
+ app-shells/bash
+ net-misc/curl[ipv6,ssl]
+ net-vpn/wireguard-tools
+ sys-apps/baselayout
+ sys-apps/coreutils
+ sys-apps/grep
+ sys-apps/iproute2[ipv6]
+ sys-apps/util-linux
+"
+BDEPEND="
+ sys-apps/coreutils
+ sys-devel/make
+"