summaryrefslogtreecommitdiff
path: root/net-vpn/i2pd/i2pd-2.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-10 09:09:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-10 09:09:16 +0000
commitf45955e60d4da9b7f4a1088c98042f9c06669039 (patch)
tree25ff171e8813c8b99f79a424124ed214a9520850 /net-vpn/i2pd/i2pd-2.16.0.ebuild
parentb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (diff)
gentoo resync : 10.12.2017
Diffstat (limited to 'net-vpn/i2pd/i2pd-2.16.0.ebuild')
-rw-r--r--net-vpn/i2pd/i2pd-2.16.0.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/net-vpn/i2pd/i2pd-2.16.0.ebuild b/net-vpn/i2pd/i2pd-2.16.0.ebuild
index de35d0cc72b1..2c29b4139a6e 100644
--- a/net-vpn/i2pd/i2pd-2.16.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.16.0.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils systemd user cmake-utils
+inherit eutils systemd user cmake-utils versionator toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="cpu_flags_x86_aes i2p-hardening libressl static +upnp websocket"
# if using libressl, require >=boost-1.65, see #597798
@@ -26,10 +26,9 @@ DEPEND="${RDEPEND}
libressl? ( dev-libs/libressl:0[static-libs]
>=dev-libs/boost-1.65 )
sys-libs/zlib[static-libs]
- upnp? ( net-libs/miniupnpc[static-libs] ) )
- websocket? ( dev-cpp/websocketpp )
- i2p-hardening? ( >=sys-devel/gcc-4.7 )
- || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )"
+ upnp? ( net-libs/miniupnpc[static-libs] )
+ )
+ websocket? ( dev-cpp/websocketpp )"
I2PD_USER=i2pd
I2PD_GROUP=i2pd
@@ -40,6 +39,15 @@ DOCS=( README.md contrib/i2pd.conf contrib/tunnels.conf )
PATCHES=( "${FILESDIR}/${PN}-2.14.0-fix_installed_components.patch" )
+pkg_pretend() {
+ if tc-is-gcc && ! version_is_at_least "4.7" "$(gcc-version)"; then
+ die "At least gcc 4.7 is required"
+ fi
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
src_configure() {
mycmakeargs=(
-DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)