summaryrefslogtreecommitdiff
path: root/net-proxy/trojan/trojan-1.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-proxy/trojan/trojan-1.12.3.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-proxy/trojan/trojan-1.12.3.ebuild')
-rw-r--r--net-proxy/trojan/trojan-1.12.3.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-proxy/trojan/trojan-1.12.3.ebuild b/net-proxy/trojan/trojan-1.12.3.ebuild
index e394deff72a0..a380f99123e8 100644
--- a/net-proxy/trojan/trojan-1.12.3.ebuild
+++ b/net-proxy/trojan/trojan-1.12.3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-any-r1 systemd
+inherit cmake python-any-r1 systemd
DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
HOMEPAGE="https://github.com/trojan-gfw/${PN}"
@@ -32,16 +32,15 @@ src_configure() {
-DENABLE_MYSQL=$(usex mysql)
-DSYSTEMD_SERVICE=ON
-DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/trojan.initd" trojan
}
src_test() {
- cmake-utils_src_test -j1
+ cmake_src_test -j1
}