summaryrefslogtreecommitdiff
path: root/net-proxy/squid/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-proxy/squid/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-proxy/squid/files')
-rw-r--r--net-proxy/squid/files/squid-3.5.7-gentoo.patch100
-rw-r--r--net-proxy/squid/files/squid-cppunit-1.14.patch417
-rw-r--r--net-proxy/squid/files/squid.confd-r112
-rw-r--r--net-proxy/squid/files/squid.cron5
-rw-r--r--net-proxy/squid/files/squid.initd-r4117
-rw-r--r--net-proxy/squid/files/squid.logrotate8
-rw-r--r--net-proxy/squid/files/squid.pam7
7 files changed, 666 insertions, 0 deletions
diff --git a/net-proxy/squid/files/squid-3.5.7-gentoo.patch b/net-proxy/squid/files/squid-3.5.7-gentoo.patch
new file mode 100644
index 000000000000..c4def050a2d0
--- /dev/null
+++ b/net-proxy/squid/files/squid-3.5.7-gentoo.patch
@@ -0,0 +1,100 @@
+diff --git a/configure.ac b/configure.ac
+index a863327..deb44ed 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,9 +26,9 @@ PRESET_CFLAGS="$CFLAGS"
+ PRESET_LDFLAGS="$LDFLAGS"
+
+ dnl Set default LDFLAGS
+-if test "x$LDFLAGS" = "x" ; then
+- LDFLAGS="-g"
+-fi
++dnl if test "x$LDFLAGS" = "x" ; then
++dnl LDFLAGS="-g"
++dnl fi
+
+ # Check for GNU cc
+ AC_PROG_CC
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 6b69267..10f506a 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -867,8 +867,8 @@ DEFAULT_LOG_PREFIX = $(DEFAULT_LOG_DIR)
+ DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
+ DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
+ DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
+-DEFAULT_NETDB_FILE = $(DEFAULT_LOG_PREFIX)/netdb.state
+-DEFAULT_SSL_DB_DIR = $(localstatedir)/lib/ssl_db
++DEFAULT_NETDB_FILE = $(localstatedir)/lib/squid/netdb.state
++DEFAULT_SSL_DB_DIR = $(localstatedir)/lib/squid/ssl_db
+ DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
+ DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
+ DEFAULT_LOGFILED = $(libexecdir)/`echo log_file_daemon | sed '$(transform);s/$$/$(EXEEXT)/'`
+diff --git a/src/debug.cc b/src/debug.cc
+index 64ab0ba..062119a 100644
+--- a/src/debug.cc
++++ b/src/debug.cc
+@@ -450,7 +450,7 @@ _db_init(const char *logfile, const char *options)
+ #if HAVE_SYSLOG && defined(LOG_LOCAL4)
+
+ if (Debug::log_syslog)
+- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, syslog_facility);
++ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, syslog_facility);
+
+ #endif /* HAVE_SYSLOG */
+
+diff --git a/src/main.cc b/src/main.cc
+index d6eb01a..0b93f0e 100644
+--- a/src/main.cc
++++ b/src/main.cc
+@@ -1657,7 +1657,7 @@ watch_child(char *argv[])
+ if (!IamMasterProcess())
+ return;
+
+- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
++ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
+
+ if ((pid = fork()) < 0)
+ syslog(LOG_ALERT, "fork failed: %s", xstrerror());
+@@ -1720,7 +1720,7 @@ watch_child(char *argv[])
+
+ if ((pid = fork()) == 0) {
+ /* child */
+- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
++ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
+ prog = argv[0];
+ argv[0] = const_cast<char*>(kid.name().termedBuf());
+ execvp(prog, argv);
+@@ -1733,7 +1733,7 @@ watch_child(char *argv[])
+ }
+
+ /* parent */
+- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
++ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
+
+ squid_signal(SIGINT, SIG_IGN, SA_RESTART);
+
+--- a/src/cf.data.pre 2013-04-29 11:17:59.256167134 +0300
++++ b/src/cf.data.pre 2013-04-29 11:20:17.043924313 +0300
+@@ -1019,6 +1019,7 @@
+ acl Safe_ports port 488 # gss-http
+ acl Safe_ports port 591 # filemaker
+ acl Safe_ports port 777 # multiling http
++acl Safe_ports port 901 # SWAT
+ acl CONNECT method CONNECT
+ NOCOMMENT_END
+ DOC_END
+@@ -5300,11 +5301,11 @@
+
+ NAME: cache_mgr
+ TYPE: string
+-DEFAULT: webmaster
++DEFAULT: root
+ LOC: Config.adminEmail
+ DOC_START
+ Email-address of local cache manager who will receive
+- mail if the cache dies. The default is "webmaster".
++ mail if the cache dies. The default is "root".
+ DOC_END
+
+ NAME: mail_from
diff --git a/net-proxy/squid/files/squid-cppunit-1.14.patch b/net-proxy/squid/files/squid-cppunit-1.14.patch
new file mode 100644
index 000000000000..f31268fc61d5
--- /dev/null
+++ b/net-proxy/squid/files/squid-cppunit-1.14.patch
@@ -0,0 +1,417 @@
+# backport rev 14707 from trunk
+--- Makefile.am 2016-01-30 09:09:25 +0000
++++ Makefile.am 2016-06-13 07:46:59 +0000
+@@ -48,7 +48,7 @@
+ check: have-cppunit check-recursive
+
+ have-cppunit:
+- @if test "$(SQUID_CPPUNIT_INC)$(SQUID_CPPUNIT_LA)$(SQUID_CPPUNIT_LIBS)" = "" ; then \
++ @if test "$(LIBCPPUNIT_CFLAGS)$(LIBCPPUNIT_LIBS)" = "" ; then \
+ echo "FATAL: 'make check' requires cppunit and cppunit development packages. They do not appear to be installed." ; \
+ exit 1 ; \
+ fi
+
+--- compat/Makefile.am 2016-02-09 08:57:33 +0000
++++ compat/Makefile.am 2016-06-13 07:46:59 +0000
+@@ -94,7 +94,7 @@
+ testPreCompiler_SOURCES= \
+ testPreCompiler.h \
+ testPreCompiler.cc
+-testPreCompiler_LDADD= $(SQUID_CPPUNIT_LA) $(SQUID_CPPUNIT_LIBS)
++testPreCompiler_LDADD= $(LIBCPPUNIT_LIBS)
+ testPreCompiler_LDFLAGS=
+
+ # os/ subdir prevents us using src/TestHeaders.am
+
+--- configure.ac 2016-06-11 05:28:18 +0000
++++ configure.ac 2016-06-13 07:46:59 +0000
+@@ -115,10 +115,11 @@
+ AC_PATH_PROG(CHMOD, chmod, $FALSE)
+ AC_PATH_PROG(TR, tr, $FALSE)
+ AC_PATH_PROG(RM, rm, $FALSE)
+-AC_PATH_PROG(CPPUNITCONFIG, cppunit-config, false)
+ dnl Libtool 2.2.6 requires: rm -f
+ RM="$RM -f"
+
++PKG_PROG_PKG_CONFIG
++
+ AC_PATH_PROG(PERL, perl, none)
+ if test "x$ac_cv_path_PERL" = "xnone"; then
+ AC_MSG_FAILURE([Perl is required to compile Squid. Please install Perl and then re-run configure ])
+@@ -984,9 +985,6 @@
+ ]
+ )
+
+-dnl Necessary if the first PKG_CHECK_MODULES call is conditional
+-PKG_PROG_PKG_CONFIG
+-
+ dnl Perform configuration consistency checks for eCAP
+ if test "x$squid_opt_use_ecap" != "xno";
+ then
+@@ -2725,45 +2723,29 @@
+ [Enable support for the X-Accelerator-Vary HTTP header])
+ AC_MSG_NOTICE([X-Accelerator-Vary support enabled: $enable_x_accelerator_vary])
+
+-
+-if $CPPUNITCONFIG --help >/dev/null; then
+- squid_cv_cppunit_version="`$CPPUNITCONFIG --version`"
+- AC_MSG_NOTICE([using system installed cppunit version $squid_cv_cppunit_version])
+- unset squid_cv_cppunit_version
+- SQUID_CPPUNIT_LIBS="`$CPPUNITCONFIG --libs`"
+- SQUID_CPPUNIT_LA=''
+- SQUID_CPPUNIT_INC="`$CPPUNITCONFIG --cflags`"
+-else
+- AC_MSG_WARN([cppunit does not appear to be installed. squid does not require this, but code testing with 'make check' will fail.])
+- SQUID_CPPUNIT_LA=''
+- SQUID_CPPUNIT_LIBS=''
+- SQUID_CPPUNIT_INC=''
+-fi
+-
+-AC_ARG_WITH(cppunit-basedir,
+- AS_HELP_STRING([--with-cppunit-basedir=PATH],
+- [Path where the cppunit headers are libraries can be found ]), [
+-if test -f "$withval/include/cppunit/TestCase.h"; then
+- AC_MSG_NOTICE([Using cppunit includes from $withval])
+- SQUID_CPPUNIT_INC="-I${withval}/include"
+-else
+- AC_MSG_ERROR(Cannot find cppunit at $withval)
+-fi
+-if test -f "$withval/lib/libcppunit.la"; then
+- AC_MSG_NOTICE([Using cppunit lib from $withval])
+- SQUID_CPPUNIT_LA="${withval}/lib/libcppunit.la"
+- SQUID_CPPUNIT_LIBS='$(SQUID_CPPUNIT_LA)'
+-else
+- AC_MSG_ERROR(Cannot find cppunit at $withval)
+-fi
+-])
+-SQUID_STATE_SAVE(squid_cppunit_state)
+-CXXFLAGS="$CXXFLAGS $SQUID_CPPUNIT_INC"
+-AC_CHECK_HEADERS(cppunit/extensions/HelperMacros.h)
+-SQUID_STATE_ROLLBACK(squid_cppunit_state)
+-AC_SUBST(SQUID_CPPUNIT_LIBS)
+-AC_SUBST(SQUID_CPPUNIT_LA)
+-AC_SUBST(SQUID_CPPUNIT_INC)
++AC_ARG_WITH([cppunit], AS_HELP_STRING([--without-cppunit],[Do not use cppunit test framework]),[
++ AS_CASE($with_cppunit, [yes|no],[],
++ [
++ AS_IF([test ! -d "$withval"],AC_MSG_ERROR([--with-cppunit PATH does not point to a directory]))
++ LIBCPPUNIT_CFLAGS="-I$with_cppunit/include"
++ LIBCPPUNIT_LIBS="-L$with_cppunit/lib -lcppunit"
++ ])
++])
++AS_IF([test "x$with_cppunit" != "xno"],[
++ PKG_CHECK_MODULES([LIBCPPUNIT],[cppunit],[
++ squid_cv_cppunit_version="`pkg-config cppunit --version`"
++ AC_MSG_NOTICE([using system installed cppunit version $squid_cv_cppunit_version])
++ AS_UNSET(squid_cv_cppunit_version)
++
++ SQUID_STATE_SAVE(squid_cppunit_state)
++ AS_VAR_APPEND(CXXFLAGS,[$LIBCPPUNIT_CFLAGS])
++ AS_VAR_APPEND(LIBS,[$LIBCPPUNIT_LIBS])
++ AC_CHECK_HEADERS(cppunit/extensions/HelperMacros.h)
++ SQUID_STATE_ROLLBACK(squid_cppunit_state)
++ ],[
++ AC_MSG_WARN([cppunit does not appear to be installed. Squid does not require this, but code testing with 'make check' will fail.])
++ ])
++])
+
+ # Force some compilers to use ANSI features
+ #
+
+--- src/Common.am 2017-06-01 16:49:00.000000000 +0300
++++ src/Common.am 2017-06-15 16:10:20.000000000 +0300
+@@ -26,7 +26,7 @@
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/src \
+ -I$(top_builddir)/include \
+- $(SQUID_CPPUNIT_INC)
++ $(LIBCPPUNIT_CFLAGS)
+
+ ## Kerberos headers require their include path.
+ ## Because we use libcompat for comm_err.h header protections ...
+--- src/Makefile.am 2017-06-01 16:49:00.000000000 +0300
++++ src/Makefile.am 2017-06-15 16:38:40.000000000 +0300
+@@ -1112,9 +1112,9 @@
+ # $(TESTSOURCES)
+ #tests_testX_LDFLAGS = $(LIBADD_DL)
+ #tests_testX_LDADD=\
+-# $(SQUID_CPPUNIT_LIBS) \
+-# $(SQUID_CPPUNIT_LA) \
+-# $(COMPAT_LIB) \
++# $(LIBCPPUNIT_LIBS) \
++# $(COMPAT_LIB) \
++# $(XTRA_LIBS)
+ #tests_testX_DEPENDENCIES= $(SQUID_CPPUNIT_LA)
+
+
+@@ -1221,8 +1221,7 @@
+ $(top_builddir)/lib/libmisccontainers.la \
+ $(top_builddir)/lib/libmiscencoding.la \
+ $(top_builddir)/lib/libmiscutil.la \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
++ $(LIBCPPUNIT_LIBS) \
+ $(NETTLELIB) \
+ $(SSLLIB) \
+ $(COMPAT_LIB) \
+@@ -1363,7 +1362,7 @@
+ $(DISK_OS_LIBS) \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(SSLLIB) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+@@ -1383,14 +1382,14 @@
+ tests/stub_MemBuf.cc \
+ $(TESTSOURCES)
+ tests_testBoilerplate_LDADD= \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
+ base/libbase.la \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testBoilerplate_LDFLAGS = $(LIBADD_DL)
+ tests_testBoilerplate_DEPENDENCIES = \
+- $(SQUID_CPPUNIT_LA)
++ $(LIBCPPUNIT_LIBS)
+
+ ## Tests of base/libbase.la objects
+ tests_testCharacterSet_SOURCES = \
+@@ -1405,9 +1404,8 @@
+ tests_testCharacterSet_LDFLAGS = $(LIBADD_DL)
+ tests_testCharacterSet_LDADD= \
+ base/libbase.la \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+- $(SQUID_CPPUNIT_LA) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(XTRA_LIBS)
+
+ ## Tests of the CacheManager module.
+@@ -1646,8 +1644,7 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
++ $(LIBCPPUNIT_LIBS) \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(COMPAT_LIB) \
+@@ -1829,8 +1826,8 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+
+@@ -2076,9 +2073,8 @@
+ $(SNMP_LIBS) \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
+ $(SSLLIB) \
++ $(LIBCPPUNIT_LIBS) \
+ $(KRB5LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+@@ -2323,10 +2319,9 @@
+ $(SNMP_LIBS) \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testEventLoop_LDFLAGS = $(LIBADD_DL)
+@@ -2564,10 +2559,9 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_test_http_range_LDFLAGS = $(LIBADD_DL)
+@@ -2613,7 +2607,7 @@
+ base/libbase.la \
+ ip/libip.la \
+ $(top_builddir)/lib/libmiscutil.la \
+- $(SQUID_CPPUNIT_LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testHttpParser_LDFLAGS = $(LIBADD_DL)
+@@ -2639,9 +2633,8 @@
+ parser/libsquid-parser.la \
+ base/libbase.la \
+ $(top_builddir)/lib/libmiscutil.la \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+- $(SQUID_CPPUNIT_LA) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(XTRA_LIBS)
+
+ ## Tests of the HttpRequest module.
+@@ -2875,10 +2868,9 @@
+ $(DISK_OS_LIBS) \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testHttpRequest_LDFLAGS = $(LIBADD_DL)
+@@ -2902,9 +2894,8 @@
+ icmp/libicmp-core.la \
+ ip/libip.la \
+ base/libbase.la \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+- $(SQUID_CPPUNIT_LA) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(XTRA_LIBS)
+
+ ## Tests for ip/* objects
+@@ -2918,9 +2909,8 @@
+ tests_testIpAddress_LDADD= \
+ ip/libip.la \
+ base/libbase.la \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+- $(SQUID_CPPUNIT_LA) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(XTRA_LIBS)
+ tests_testIpAddress_LDFLAGS= $(LIBADD_DL)
+
+@@ -3087,10 +3077,10 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
+ CommCalls.o \
+ DnsLookupDetails.o \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testStore_LDFLAGS = $(LIBADD_DL)
+@@ -3130,8 +3120,8 @@
+ ip/libip.la \
+ $(top_builddir)/lib/libmiscutil.la \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testString_LDFLAGS = $(LIBADD_DL)
+@@ -3326,8 +3316,8 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testUfs_LDFLAGS = $(LIBADD_DL)
+@@ -3506,8 +3496,8 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testRock_LDFLAGS = $(AM_CPPFLAGS) $(LIBADD_DL)
+@@ -3751,10 +3741,9 @@
+ $(top_builddir)/lib/libmiscutil.la \
+ $(NETTLELIB) \
+ $(COMPAT_LIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testURL_LDFLAGS = $(LIBADD_DL)
+@@ -3794,7 +3783,7 @@
+ mgr/libmgr.la \
+ $(top_builddir)/lib/libmiscutil.la \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testSBuf_DEPENDENCIES= $(SQUID_CPPUNIT_LA)
+@@ -3838,7 +3827,7 @@
+ ip/libip.la \
+ mgr/libmgr.la \
+ $(top_builddir)/lib/libmiscutil.la \
+- $(SQUID_CPPUNIT_LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testSBufList_DEPENDENCIES= $(SQUID_CPPUNIT_LA)
+@@ -3876,8 +3865,8 @@
+ ip/libip.la \
+ $(top_builddir)/lib/libmiscutil.la \
+ $(REGEXLIB) \
+- $(SQUID_CPPUNIT_LIBS) \
+ $(SSLLIB) \
++ $(LIBCPPUNIT_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testConfigParser_LDFLAGS = $(LIBADD_DL)
+@@ -3922,9 +3911,9 @@
+ base/libbase.la \
+ $(top_builddir)/lib/libmiscutil.la \
+ $(top_builddir)/lib/libmisccontainers.la \
+- $(SQUID_CPPUNIT_LIBS) \
+- $(SQUID_CPPUNIT_LA) \
+- $(COMPAT_LIB)
++ $(LIBCPPUNIT_LIBS) \
++ $(COMPAT_LIB) \
++ $(XTRA_LIBS)
+ tests_testStatHist_DEPENDENCIES = $(SQUID_CPPUNIT_LA)
+
+ TESTS += testHeaders
+--- lib/Makefile.am 2017-06-01 16:49:00.000000000 +0300
++++ lib/Makefile.am 2017-06-16 07:19:54.000000000 +0300
+@@ -91,7 +91,7 @@
+ tests/testRFC1035.cc
+
+ tests_testRFC1035_LDADD= \
+- $(SQUID_CPPUNIT_LA) $(SQUID_CPPUNIT_LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(top_builddir)/lib/libmiscencoding.la \
+ $(top_builddir)/lib/libmiscutil.la \
+ $(COMPAT_LIB)
+@@ -103,7 +103,7 @@
+ tests/testRFC1738.cc
+
+ tests_testRFC1738_LDADD= \
+- $(SQUID_CPPUNIT_LA) $(SQUID_CPPUNIT_LIBS) \
++ $(LIBCPPUNIT_LIBS) \
+ $(top_builddir)/lib/libmiscencoding.la \
+ $(top_builddir)/lib/libmiscutil.la \
+ $(COMPAT_LIB)
diff --git a/net-proxy/squid/files/squid.confd-r1 b/net-proxy/squid/files/squid.confd-r1
new file mode 100644
index 000000000000..a29d33defb07
--- /dev/null
+++ b/net-proxy/squid/files/squid.confd-r1
@@ -0,0 +1,12 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Config file for /etc/init.d/squid
+
+SQUID_OPTS="-YC"
+
+# Kerberos keytab file to use. This is required if you enable kerberos authentication.
+SQUID_KEYTAB=""
+
+# Use max_filedescriptors setting in squid.conf to determine the maximum number
+# of filedescriptors squid can open.
diff --git a/net-proxy/squid/files/squid.cron b/net-proxy/squid/files/squid.cron
new file mode 100644
index 000000000000..8726ddd72955
--- /dev/null
+++ b/net-proxy/squid/files/squid.cron
@@ -0,0 +1,5 @@
+#!/bin/sh
+if test -e /var/run/squid.pid ; then
+ test -n "$(cat /var/run/squid.pid|xargs ps -p|grep squid)" && \
+ /usr/sbin/squid -k rotate
+fi
diff --git a/net-proxy/squid/files/squid.initd-r4 b/net-proxy/squid/files/squid.initd-r4
new file mode 100644
index 000000000000..3e84eda38a6d
--- /dev/null
+++ b/net-proxy/squid/files/squid.initd-r4
@@ -0,0 +1,117 @@
+#!/sbin/openrc-run
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_started_commands="reload rotate"
+
+depend() {
+ use dns net
+}
+
+checkconfig() {
+ if [ ! -f /etc/squid/${SVCNAME}.conf ]; then
+ eerror "You need to create /etc/squid/${SVCNAME}.conf first."
+ eerror "An example can be found in /etc/squid/squid.conf.default"
+ return 1
+ fi
+
+ local PIDFILE=$(awk '/^[ \t]*pid_filename[ \t]+/ { print $2 }' < /etc/squid/${SVCNAME}.conf)
+ [ -z ${PIDFILE} ] && PIDFILE=/run/squid.pid
+ if [ /run/${SVCNAME}.pid != ${PIDFILE} ]; then
+ eerror "/etc/squid/${SVCNAME}.conf must set pid_filename to"
+ eerror " /run/${SVCNAME}.pid"
+ eerror "CAUTION: http_port, cache_dir and *_log parameters must be different than"
+ eerror " in any other instance of squid."
+ return 1
+ fi
+
+ # Maximum file descriptors squid can open is determined by:
+ # a basic default of N=1024
+ # ... altered by ./configure --with-filedescriptors=N
+ # ... overridden on production by squid.conf max_filedescriptors (if,
+ # and only if, setrlimit() RLIMIT_NOFILE is able to be built+used).
+ # Since we do not configure hard coded # of filedescriptors anymore,
+ # there is no need for ulimit calls in the init script.
+ # Use max_filedescriptors in squid.conf instead.
+
+ local CACHE_SWAP=$(awk '/^[ \t]*cache_dir[ \t]+/ { if ( $2 == "rock" ) printf "%s/rock ", $3; else if ( $2 == "coss" ) printf "%s/stripe ", $3; else printf "%s/00 ", $3; }' < /etc/squid/${SVCNAME}.conf)
+ [ -z "$CACHE_SWAP" ] && CACHE_SWAP="/var/cache/squid/00"
+
+ local x
+ for x in $CACHE_SWAP ; do
+ if [ ! -e $x ] ; then
+ ebegin "Initializing cache directory ${x%/*}"
+ local ORIG_UMASK=$(umask)
+ umask 027
+
+ if ! (mkdir -p ${x%/*} && chown squid ${x%/*}) ; then
+ eend 1
+ return 1
+ fi
+
+ local INIT_CACHE_RESPONSE="$(/usr/sbin/squid -z -N -f /etc/squid/${SVCNAME}.conf 2>&1)"
+ if [ $? != 0 ] || echo "$INIT_CACHE_RESPONSE" | grep -q "erminated abnormally" ; then
+ umask $ORIG_UMASK
+ eend 1
+ echo "$INIT_CACHE_RESPONSE"
+ return 1
+ fi
+
+ umask $ORIG_UMASK
+ eend 0
+ break
+ fi
+ done
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+ checkpath -d -q -m 0750 -o squid:squid /run/${SVCNAME}
+
+ ebegin "Starting ${SVCNAME}"
+ KRB5_KTNAME="${SQUID_KEYTAB}" /usr/sbin/squid ${SQUID_OPTS} -f /etc/squid/${SVCNAME}.conf
+ eend $? && sleep 1
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ if /usr/sbin/squid -k shutdown -f /etc/squid/${SVCNAME}.conf ; then
+ # Now we have to wait until squid has _really_ stopped.
+ sleep 1
+ if [ -f /run/${SVCNAME}.pid ] ; then
+ einfon "Waiting for squid to shutdown ."
+ cnt=0
+ while [ -f /run/${SVCNAME}.pid ] ; do
+ cnt=$(expr $cnt + 1)
+ if [ $cnt -gt 60 ] ; then
+ # Waited 120 seconds now. Fail.
+ echo
+ eend 1 "Failed."
+ break
+ fi
+ sleep 2
+ echo -n "."
+ done
+ echo
+ fi
+ else
+ eerror "Squid shutdown failed, probably service is already down."
+ fi
+ eend 0
+}
+
+reload() {
+ checkconfig || return 1
+ ebegin "Reloading ${SVCNAME}"
+ /usr/sbin/squid -k reconfigure -f /etc/squid/${SVCNAME}.conf
+ eend $?
+}
+
+rotate() {
+ service_started ${SVCNAME} || return 1
+ ebegin "Rotating ${SVCNAME} logs"
+ /usr/sbin/squid -k rotate -f /etc/squid/${SVCNAME}.conf
+ eend $?
+}
diff --git a/net-proxy/squid/files/squid.logrotate b/net-proxy/squid/files/squid.logrotate
new file mode 100644
index 000000000000..5bf289691aec
--- /dev/null
+++ b/net-proxy/squid/files/squid.logrotate
@@ -0,0 +1,8 @@
+/var/log/squid/*.log {
+ copytruncate
+ compress
+ notifempty
+ missingok
+ sharedscripts
+}
+
diff --git a/net-proxy/squid/files/squid.pam b/net-proxy/squid/files/squid.pam
new file mode 100644
index 000000000000..75eeaa9db38d
--- /dev/null
+++ b/net-proxy/squid/files/squid.pam
@@ -0,0 +1,7 @@
+#%PAM-1.0
+auth required pam_nologin.so
+auth include system-auth
+account include system-auth
+password include system-auth
+session optional pam_limits.so
+session include system-auth