summaryrefslogtreecommitdiff
path: root/net-proxy/piper/piper-1.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-proxy/piper/piper-1.14.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-proxy/piper/piper-1.14.ebuild')
-rw-r--r--net-proxy/piper/piper-1.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-proxy/piper/piper-1.14.ebuild b/net-proxy/piper/piper-1.14.ebuild
new file mode 100644
index 000000000000..9d0e6cf38cea
--- /dev/null
+++ b/net-proxy/piper/piper-1.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Piper (a tool for manipulating SOCKS5 servers)"
+HOMEPAGE="http://www.qwirx.com/"
+SRC_URI="http://www.qwirx.com/piper/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND=""
+#RDEPEND=""
+
+src_compile() {
+ append-flags -g -Wall
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin piper
+ dodoc README
+}