summaryrefslogtreecommitdiff
path: root/net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild')
-rw-r--r--net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild b/net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild
new file mode 100644
index 000000000000..67c9373c73f7
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-5.2-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/click-6.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.9[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/hyper-h2-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.5[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-1.5.4[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.11.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/flask-1.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.50.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.8.1[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/urwid/s/==2\.0\.1,!=2\.1\.0//' \
+ setup.py || die
+
+ # remove failing test
+ sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ # https://github.com/mitmproxy/mitmproxy/issues/4136
+ # https://bugs.gentoo.org/740336
+ rm test/mitmproxy/addons/test_termlog.py || die
+
+ # requires asynctest
+ rm test/mitmproxy/addons/test_readfile.py || die
+
+ # Passes with OpenSSL 1.1.1g, fails with OpenSSL 1.1.1h
+ # https://github.com/gentoo/gentoo/pull/17411#discussion_r497270699
+ sed \
+ -e 's/test_mode_none_should_pass_without_sni/_&/g' \
+ -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
+ -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
+ -i test/mitmproxy/net/test_tcp.py || die
+ sed \
+ -e 's/test_verification_w_confdir/_&/g' \
+ -e 's/test_verification_w_pemfile/_&/g' \
+ -i test/mitmproxy/proxy/test_server.py || die
+
+ distutils-r1_python_prepare_all
+}