summaryrefslogtreecommitdiff
path: root/net-proxy/lyrebird
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 01:36:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 01:36:25 +0100
commitdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (patch)
treea62738c03c7054c5e9671a2f1d43542b84db1bfa /net-proxy/lyrebird
parentf2381eb1a950bcf1b75077ca00e589b06a905cc7 (diff)
gentoo auto-resync : 28:06:2023 - 01:36:25
Diffstat (limited to 'net-proxy/lyrebird')
-rw-r--r--net-proxy/lyrebird/Manifest7
-rw-r--r--net-proxy/lyrebird/lyrebird-0.0.14.ebuild33
-rw-r--r--net-proxy/lyrebird/lyrebird-0.1.0.ebuild43
-rw-r--r--net-proxy/lyrebird/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/net-proxy/lyrebird/Manifest b/net-proxy/lyrebird/Manifest
new file mode 100644
index 000000000000..42f0f6fab585
--- /dev/null
+++ b/net-proxy/lyrebird/Manifest
@@ -0,0 +1,7 @@
+DIST lyrebird-0.1.0-deps.tar.xz 88991580 BLAKE2B ba9113d847bc900ad3001e91a67ac939a7fbd8f7423f256be92a5fb2461604c00e05edd581a28f456f493997d31a40fa1673fead1cd15ae192e02ca480b9db5b SHA512 af6e245ac333de1c14ba1f648548123f11ceaffb894d4057e2e7ed5c1fa8cd0f023e308ccf20d74696b2ef0b8a0489fe2f73c868dc23e087f8ae04ea6688db4d
+DIST lyrebird-0.1.0.tar.bz2 76753 BLAKE2B af168a25093b68b10b489adc282f1ee65b70193602f79d9cc352c78e2a9c71205191dc6487ea58584f76ce1cbbf653d3fd0e1f645d7972d3e73173a90ae39361 SHA512 f9b8686d1c5f9ddb41a255a1a8954e05cefd50523ada7360432b456c62475ba606872df407ba8ebd7714d4f185eef0efae63e3e53c5c1c18fd323a97912f951e
+DIST obfs4proxy-0.0.14-deps.tar.xz 23134868 BLAKE2B befa45afeb9566dbf46be07ae469dca305d91584b04f6cb8529c50c2d1b3fb94e0adc6434ffa069b8fa1af6be2a29ffc550a7bcf1aa45eac0ed66252e37a31f8 SHA512 81f4bb778230c2f040dd1682ffaff3a635d4a57a5cef42b9d4ff7df486476cb037d7851d6e8ce5bb021c6a9a5116355e963eccfc2d1fd94cbc24df21bff7ff2e
+DIST obfs4proxy-0.0.14.tar.gz 88649 BLAKE2B 6d2198dee67998b1793c28d77dbfd8f922248e8acba481ea9496567652e132fe45c09061b3052dcdebe0dbc356744ea454641789dc688ed333ede73186b8c69a SHA512 2e28516ab888485d14d7f60fc0bee9a8268faf681803c71faff49185b7870cc0c5a6df3dbbb2a4d446307997812092ca64070be978997bc82cc89ee435698feb
+EBUILD lyrebird-0.0.14.ebuild 907 BLAKE2B ee62956d0bc30951cfebf1aee6f63b250ccb3d5b3e9ea2d5b331b201427bfa96a207ccc525f619be877fa84b25d98fdb0c57b4b0cff4113badee7f6202824326 SHA512 efdaf2e6fcc1639bad14da366c23ff6b56033e123d9cebdeb7319e52152c4428978edb910371c891b8e92f942267383aec98fa689b3d0e12c3a5213137f13241
+EBUILD lyrebird-0.1.0.ebuild 1178 BLAKE2B 4f02ca41ae07f3972105daff94e8ef184fa215a70aea109a7671297d4eb0912c2427dff94132dd8fcc71476487ae7a60621b85a4535db0fccf3f7695f251ae10 SHA512 6368ba33d6b0f888b4101ac05823f939caf0569f1744461e5693ccc092ffc3dac35f1e922f02d7109e1bcf0f88c104ad7c23efe4c29a7500db66c2edb8fe7a33
+MISC metadata.xml 246 BLAKE2B f808bbbcb9c53d005d1a1667cd6217a601a3bd3bd2267121c0043a870ae44bb91bb27bc9825d5d6eafe01b73fe58a553655aa252737c0b066f2286ff9415d65e SHA512 b620abb7732628010a8a3792d40bde878492be97ce14c99c4d2466240df2f25edf7734ad4d210bc954f27323f0e26698e660766c65be5868646a3866020373fd
diff --git a/net-proxy/lyrebird/lyrebird-0.0.14.ebuild b/net-proxy/lyrebird/lyrebird-0.0.14.ebuild
new file mode 100644
index 000000000000..44f0e12e63e3
--- /dev/null
+++ b/net-proxy/lyrebird/lyrebird-0.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+MY_PN="obfs4proxy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An obfuscating proxy supporting Tor's pluggable transport protocol obfs4"
+HOMEPAGE="https://gitlab.com/yawning/obfs4"
+SRC_URI="https://gitlab.com/yawning/obfs4/-/archive/${MY_P}/obfs4-${MY_P}.tar.gz -> ${MY_P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${MY_P}-deps.tar.xz"
+
+# See https://gitlab.com/yawning/obfs4/-/issues/5#note_573104796 for licence clarification
+LICENSE="BSD CC0-1.0 BZIP2 GPL-3+ MIT public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm ~riscv x86"
+
+S="${WORKDIR}/obfs4-${MY_P}"
+
+DOCS=( README.md ChangeLog LICENSE-GPL3.txt doc/obfs4-spec.txt )
+
+src_compile() {
+ go build -o ${MY_PN}/${MY_PN} ./${MY_PN} || die
+}
+
+src_install() {
+ default
+ dobin ${MY_PN}/${MY_PN}
+ doman doc/${MY_PN}.1
+}
diff --git a/net-proxy/lyrebird/lyrebird-0.1.0.ebuild b/net-proxy/lyrebird/lyrebird-0.1.0.ebuild
new file mode 100644
index 000000000000..34cb1326cb3f
--- /dev/null
+++ b/net-proxy/lyrebird/lyrebird-0.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="An obfuscating proxy supporting Tor's pluggable transport protocol obfs4"
+HOMEPAGE="https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+SRC_URI="https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/${PN}/-/archive/${P}/${PN}-${P}.tar.bz2 -> ${P}.tar.bz2
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD CC0-1.0 BZIP2 GPL-3+ MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+S="${WORKDIR}"/${PN}-${P}
+
+DOCS=( README.md ChangeLog doc/obfs4-spec.txt )
+
+src_compile() {
+ go build ./cmd/${PN} || die
+}
+
+src_install() {
+ default
+ dobin ${PN}
+ newman doc/obfs4proxy.1 ${PN}.1
+}
+
+pkg_postinst() {
+ if [[ ! -z "${REPLACING_VERSIONS}" ]]; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 0.1.0; then
+ ewarn "Since version 0.1.0 the proxy executable is called '${PN}' rather than 'obfs4proxy'."
+ ewarn "Please update your Tor configuration accordingly."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
diff --git a/net-proxy/lyrebird/metadata.xml b/net-proxy/lyrebird/metadata.xml
new file mode 100644
index 000000000000..beac02a9af14
--- /dev/null
+++ b/net-proxy/lyrebird/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+</pkgmetadata>