summaryrefslogtreecommitdiff
path: root/net-proxy/lyrebird/lyrebird-0.0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 01:36:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 01:36:25 +0100
commitdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (patch)
treea62738c03c7054c5e9671a2f1d43542b84db1bfa /net-proxy/lyrebird/lyrebird-0.0.14.ebuild
parentf2381eb1a950bcf1b75077ca00e589b06a905cc7 (diff)
gentoo auto-resync : 28:06:2023 - 01:36:25
Diffstat (limited to 'net-proxy/lyrebird/lyrebird-0.0.14.ebuild')
-rw-r--r--net-proxy/lyrebird/lyrebird-0.0.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-proxy/lyrebird/lyrebird-0.0.14.ebuild b/net-proxy/lyrebird/lyrebird-0.0.14.ebuild
new file mode 100644
index 000000000000..44f0e12e63e3
--- /dev/null
+++ b/net-proxy/lyrebird/lyrebird-0.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+MY_PN="obfs4proxy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An obfuscating proxy supporting Tor's pluggable transport protocol obfs4"
+HOMEPAGE="https://gitlab.com/yawning/obfs4"
+SRC_URI="https://gitlab.com/yawning/obfs4/-/archive/${MY_P}/obfs4-${MY_P}.tar.gz -> ${MY_P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${MY_P}-deps.tar.xz"
+
+# See https://gitlab.com/yawning/obfs4/-/issues/5#note_573104796 for licence clarification
+LICENSE="BSD CC0-1.0 BZIP2 GPL-3+ MIT public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm ~riscv x86"
+
+S="${WORKDIR}/obfs4-${MY_P}"
+
+DOCS=( README.md ChangeLog LICENSE-GPL3.txt doc/obfs4-spec.txt )
+
+src_compile() {
+ go build -o ${MY_PN}/${MY_PN} ./${MY_PN} || die
+}
+
+src_install() {
+ default
+ dobin ${MY_PN}/${MY_PN}
+ doman doc/${MY_PN}.1
+}