summaryrefslogtreecommitdiff
path: root/net-proxy/hatop/hatop-0.7.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-proxy/hatop/hatop-0.7.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-proxy/hatop/hatop-0.7.7.ebuild')
-rw-r--r--net-proxy/hatop/hatop-0.7.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-proxy/hatop/hatop-0.7.7.ebuild b/net-proxy/hatop/hatop-0.7.7.ebuild
new file mode 100644
index 000000000000..f1114a42e99f
--- /dev/null
+++ b/net-proxy/hatop/hatop-0.7.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="Ncurses client and real-time monitoring and displaying of HAProxy status"
+HOMEPAGE="http://feurix.org/projects/hatop/"
+SRC_URI="https://hatop.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ net-proxy/haproxy"
+
+src_install() {
+ python_foreach_impl python_doscript bin/hatop
+
+ doman man/hatop.1
+
+ dodoc CHANGES KEYBINDS README
+}