summaryrefslogtreecommitdiff
path: root/net-proxy/haproxy/haproxy-2.2.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 15:10:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 15:10:46 +0000
commitee8ad1509f726e8fa598472117e5bbffd241ebab (patch)
tree4ac9a10ae4694145a7287533143f85af923c1954 /net-proxy/haproxy/haproxy-2.2.9999.ebuild
parent1fe7aef6facf013a94eac853717f4da4d5d3c5b3 (diff)
gentoo auto-resync : 06:12:2022 - 15:10:45
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.2.9999.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.2.9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-proxy/haproxy/haproxy-2.2.9999.ebuild b/net-proxy/haproxy/haproxy-2.2.9999.ebuild
index c3fd5e9e2c2b..2bf20bf3ac64 100644
--- a/net-proxy/haproxy/haproxy-2.2.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.9999.ebuild
@@ -108,14 +108,16 @@ src_compile() {
fi
# HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
- emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" EXTRA_OBJS="${EXTRA_OBJS}" TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
+ emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" EXTRA_OBJS="${EXTRA_OBJS}" \
+ TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
emake -C contrib/systemd SBINDIR=/usr/sbin
if use tools ; then
for contrib in ${CONTRIBS[@]} ; do
# Those two includes are a workaround for hpack Makefile missing those
emake -C contrib/${contrib} \
- CFLAGS="${CFLAGS} -I../../include/ -I../../ebtree/" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" ${args[@]}
+ CFLAGS="${CFLAGS} -I../../include/ -I../../ebtree/" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" ${args[@]}
done
fi
}