summaryrefslogtreecommitdiff
path: root/net-proxy/dnsproxy/dnsproxy-1.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-proxy/dnsproxy/dnsproxy-1.17.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-proxy/dnsproxy/dnsproxy-1.17.ebuild')
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.17.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-proxy/dnsproxy/dnsproxy-1.17.ebuild b/net-proxy/dnsproxy/dnsproxy-1.17.ebuild
new file mode 100644
index 000000000000..77a4f6123f42
--- /dev/null
+++ b/net-proxy/dnsproxy/dnsproxy-1.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
+HOMEPAGE="https://www.wolfermann.org/dnsproxy.html"
+SRC_URI="https://www.wolfermann.org/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/libevent
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.16-include.patch
+)
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake ${PN}
+}
+
+src_install() {
+ dosbin ${PN}
+ keepdir /var/empty
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ insinto /etc/${PN}
+ newins ${PN}.conf ${PN}.conf.dist
+
+ dodoc README
+ doman ${PN}.1
+}