summaryrefslogtreecommitdiff
path: root/net-proxy/cntlm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /net-proxy/cntlm/files
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'net-proxy/cntlm/files')
-rw-r--r--net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch8
-rw-r--r--net-proxy/cntlm/files/cntlm-0.93_beta5-configure-clang16.patch31
2 files changed, 35 insertions, 4 deletions
diff --git a/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch b/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
index d553e8661484..d6df267582d4 100644
--- a/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
+++ b/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
@@ -1,8 +1,8 @@
Gentoo Bug#334647:
Respect CC, CFLAGS, LDFLAGS (with gcc).
Support verbose building via 'make V=1'.
---- configure.orig 2012-10-02 14:01:48.735669564 +0200
-+++ configure 2012-10-02 14:23:01.224271511 +0200
+--- a/configure.orig
++++ b/configure
@@ -10,7 +10,7 @@
# This can be disabled if neccessary.
#
@@ -57,8 +57,8 @@ Support verbose building via 'make V=1'.
rc=$?
if [ $rc -ne 0 ]; then # -o -n "$OUT" ]; then
---- Makefile.orig 2012-10-02 15:31:03.986270993 +0200
-+++ Makefile 2012-10-02 15:40:10.277689068 +0200
+--- a/Makefile.orig
++++ b/Makefile
@@ -16,14 +16,13 @@
CC := gcc
VER := $(shell cat VERSION)
diff --git a/net-proxy/cntlm/files/cntlm-0.93_beta5-configure-clang16.patch b/net-proxy/cntlm/files/cntlm-0.93_beta5-configure-clang16.patch
new file mode 100644
index 000000000000..3cfde3cbbd5a
--- /dev/null
+++ b/net-proxy/cntlm/files/cntlm-0.93_beta5-configure-clang16.patch
@@ -0,0 +1,31 @@
+Based on https://sourceforge.net/p/cntlm/bugs/79/ but rebased on our cntlm-0.93_beta5-buildsystem.patch.
+--- a/Makefile
++++ b/Makefile
+@@ -20,7 +20,7 @@ LIBS := $(shell [ $(OS) = "SunOS" ] && echo "-lrt -lsocket -lnsl")
+ LDFLAGS := -pthread
+ CYGWIN_REQS := cygwin1.dll cyggcc_s-1.dll cygstdc++-6.dll cygrunsrv.exe
+
+-CFLAGS=-D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
++CFLAGS=-D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -D_DEFAULT_SOURCE -DVERSION=\"'$(VER)'\"
+ ifeq ($(DEBUG),1)
+ CFLAGS += -g -O0
+ endif
+--- a/config/gethostname.c
++++ b/config/gethostname.c
+@@ -1,3 +1,5 @@
++#include <stdio.h>
++#include <string.h>
+ #include <unistd.h>
+
+ int main(int argc, char **argv) {
+--- a/configure
++++ b/configure
+@@ -67,7 +67,7 @@ rm -f $CONFIG
+ for i in $TESTS; do
+ printf "Checking $i... "
+ printf "#define config_$i " >> $CONFIG
+- OUT=`$CC $CFLAGS $LDFLAGS -D_POSIX_C_SOURCE=199506L -D_ISOC99_SOURCE -D_REENTRANT -o config/$i config/$i.c 2>&1`
++ OUT=`$CC $CFLAGS $LDFLAGS -D_POSIX_C_SOURCE=199506L -D_ISOC99_SOURCE -D_DEFAULT_SOURCE -D_REENTRANT -o config/$i config/$i.c 2>&1`
+ rc=$?
+
+ if [ $rc -ne 0 ]; then # -o -n "$OUT" ]; then