summaryrefslogtreecommitdiff
path: root/net-proxy/3proxy/3proxy-0.8.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-proxy/3proxy/3proxy-0.8.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-proxy/3proxy/3proxy-0.8.9.ebuild')
-rw-r--r--net-proxy/3proxy/3proxy-0.8.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-proxy/3proxy/3proxy-0.8.9.ebuild b/net-proxy/3proxy/3proxy-0.8.9.ebuild
new file mode 100644
index 000000000000..c8979db8e54d
--- /dev/null
+++ b/net-proxy/3proxy/3proxy-0.8.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
+DESCRIPTION="A really tiny cross-platform proxy servers set"
+HOMEPAGE="https://www.3proxy.ru/"
+SRC_URI="https://github.com/z3APA3A/3proxy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8-gentoo.patch
+)
+
+DOCS=( README cfg )
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+ default
+ cp Makefile.Linux Makefile || die
+}
+
+src_install() {
+ local x
+
+ pushd src >/dev/null || die
+ dobin 3proxy
+ for x in proxy socks ftppr pop3p tcppm udppm mycrypt dighosts icqpr smtpp; do
+ newbin ${x} ${PN}-${x}
+ [[ -f "${S}"/man/${x}.8 ]] && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+ done
+ popd >/dev/null
+
+ doman man/3proxy*.[38]
+
+ einstalldocs
+}