summaryrefslogtreecommitdiff
path: root/net-print
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
commitd5ee59790ee8298b8599b0aa0fa21a98b972a44d (patch)
tree2cc4393cdcfae28879cee110e5975f6e6b798f91 /net-print
parentd855918b46ba8714cf1320fe63b55fd0ed1748a6 (diff)
gentoo auto-resync : 30:06:2024 - 08:00:50
Diffstat (limited to 'net-print')
-rw-r--r--net-print/Manifest.gzbin6428 -> 6429 bytes
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.24.4.ebuild71
3 files changed, 73 insertions, 0 deletions
diff --git a/net-print/Manifest.gz b/net-print/Manifest.gz
index e6e6cb114d8c..f202e58ecc45 100644
--- a/net-print/Manifest.gz
+++ b/net-print/Manifest.gz
Binary files differ
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 13d1e2d88373..5f28d1cd4eca 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
DIST hplip-3.23.12-plugin.run 11491524 BLAKE2B 9b87522a78588d65815992a170451888b4c6ac83809498fae01cfa4d2c333657a7cf49f2358e12ebfd0ae0f4169e29729e9ef8ba6716f74de0a83b11552275e3 SHA512 933c27040443584e0cfda71b50b8a251ebd34fdf4a2c90f40e36d1c155b3ae87c1474835356f685de2997469b4b7a3f000e216fd427118eea2542fa142783ab9
+DIST hplip-3.24.4-plugin.run 11490921 BLAKE2B 8eeb0a292b1a132841c2d69808441b281de04950be2b906a5906b36b634f30ed42484cc14ac232ef4c50ae5e660c5e48e2afc407e64b12f1b8deb7cf38425bf2 SHA512 21b1636d4d4f7f1673f1a88abc13f4f81c225d6a36a4d45f4f0579ec5ca9bb4a3885ffd413ab6888290c3e2aa62eef45a27cd5eb84c8f20ef3e6c09e24c854b9
EBUILD hplip-plugin-3.23.12.ebuild 1483 BLAKE2B c75f0e9c64e2f71916ec9b8a67b41faefffee00cce74e3ab2df526b271b90b26cd20ccbd0549cd43e0362f33650158b17334a063260a65734cf673ef8e9606d4 SHA512 166432f69b79f75c142db0febcb91cdccb9ecea2a98bf1a9afd6f10cc5ee52b357fd21772ededa54dcb6842400b34368659cfca51af33578c4cc292c58a5099c
+EBUILD hplip-plugin-3.24.4.ebuild 1487 BLAKE2B d84b9416e2d8f29a3aef8c0d96e89116e4f6cdb282e6d8a4eac5ff7e6a26256dda52062945ada8ac6182186a049ab875665af0c0b645cde5f14916a2847f166c SHA512 31c6702526a7ef33ec665a4a89dc84d43e75485283d5ffa36083f6496d450d5b0694b97fc1496df64a905898a41f2fe23b5ef4bc18f45b4b4fe817d20feb3c73
MISC metadata.xml 523 BLAKE2B 396a3e3f19f1929ac628fd3301f7de077e34d80b88f0f65dd4035a55b8ff16be6a89dc94b47085dafc7a8a2def19353aa52996a12e51e94154a61ba1329f8c91 SHA512 9d5abebbd6fdac76142c70aa911c4ac55eb5388fd39e010d72e8e6253f51a7924eda2a675cd8ce3475fea76b307805644cf8f7140b265e66b4fcd65a8546fd96
diff --git a/net-print/hplip-plugin/hplip-plugin-3.24.4.ebuild b/net-print/hplip-plugin/hplip-plugin-3.24.4.ebuild
new file mode 100644
index 000000000000..2325efad4421
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.24.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}