summaryrefslogtreecommitdiff
path: root/net-print/lm1100/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-print/lm1100/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-print/lm1100/files')
-rw-r--r--net-print/lm1100/files/lm1100-1.0.2a-class.patch24
-rw-r--r--net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-3.4.patch22
-rw-r--r--net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-4.1.patch73
-rw-r--r--net-print/lm1100/files/lm1100-1.0.2a-makefile.patch35
-rw-r--r--net-print/lm1100/files/lm1100maint-firmware.patch14
5 files changed, 168 insertions, 0 deletions
diff --git a/net-print/lm1100/files/lm1100-1.0.2a-class.patch b/net-print/lm1100/files/lm1100-1.0.2a-class.patch
new file mode 100644
index 000000000000..b771e1bf1449
--- /dev/null
+++ b/net-print/lm1100/files/lm1100-1.0.2a-class.patch
@@ -0,0 +1,24 @@
+diff -ur lm1100.1.0.2a~/PaintLine300c.h lm1100.1.0.2a/PaintLine300c.h
+--- lm1100.1.0.2a~/PaintLine300c.h 2006-06-22 15:14:36.000000000 +0200
++++ lm1100.1.0.2a/PaintLine300c.h 2006-06-22 15:14:55.000000000 +0200
+@@ -32,7 +32,7 @@
+ int size;
+ int x,y;
+
+- friend LexmarkProtocol300c;
++ friend class LexmarkProtocol300c;
+
+ public:
+ void pad(int pad_amount);
+diff -ur lm1100.1.0.2a~/PaintLineBW.h lm1100.1.0.2a/PaintLineBW.h
+--- lm1100.1.0.2a~/PaintLineBW.h 2006-06-22 15:14:36.000000000 +0200
++++ lm1100.1.0.2a/PaintLineBW.h 2006-06-22 15:14:55.000000000 +0200
+@@ -33,7 +33,7 @@
+ int size;
+ int x,y;
+
+- friend LexmarkProtocolBW;
++ friend class LexmarkProtocolBW;
+
+ public:
+ void pad(int pad_amount);
diff --git a/net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-3.4.patch b/net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-3.4.patch
new file mode 100644
index 000000000000..60e1b5c2e7a3
--- /dev/null
+++ b/net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-3.4.patch
@@ -0,0 +1,22 @@
+--- LexmarkProtocol300c.cc.orig 2000-11-21 09:06:22.000000000 +0100
++++ LexmarkProtocol300c.cc 2004-06-16 13:28:04.397060286 +0200
+@@ -69,7 +69,7 @@
+ Jet **LexmarkProtocol300c::createJets(int *numJets, Map *imageMap)
+ {
+ *numJets = 6;
+- class Jet **jets = new (Jet *)[6];
++ class Jet **jets = new Jet*[6];
+ jets[0] = new Jet(0,9,0,imageMap,LEFT_JET,0,8);
+ jets[1] = new Jet(1,0,0,imageMap,RIGHT_JET,0,8);
+ jets[2] = new Jet(2,-9,20,imageMap,LEFT_JET,1,8);
+--- LexmarkProtocolBW.cc.orig 2000-11-21 09:06:22.000000000 +0100
++++ LexmarkProtocolBW.cc 2004-06-16 13:32:51.291509280 +0200
+@@ -68,7 +68,7 @@
+ Jet **LexmarkProtocolBW::createJets(int *numJets, Map *imageMap)
+ {
+ *numJets = 2;
+- class Jet **jets = new (Jet *)[2];
++ class Jet **jets = new Jet*[2];
+ jets[0] = new Jet(0,9,0,imageMap,LEFT_JET,0,28);
+ jets[1] = new Jet(0,0,0,imageMap,RIGHT_JET,0,28);
+
diff --git a/net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-4.1.patch b/net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-4.1.patch
new file mode 100644
index 000000000000..bc797a09a44b
--- /dev/null
+++ b/net-print/lm1100/files/lm1100-1.0.2a-fix-compile-gcc-4.1.patch
@@ -0,0 +1,73 @@
+diff -ru lm1100.1.0.2a~/Jet.h lm1100.1.0.2a/Jet.h
+--- lm1100.1.0.2a~/Jet.h 2006-12-02 18:48:16.000000000 +0100
++++ lm1100.1.0.2a/Jet.h 2006-12-02 18:49:54.000000000 +0100
+@@ -45,7 +45,7 @@
+ Coord imageStart; // start of image from edge of paper
+
+ bool insideImage(int x, int y);
+- bool Jet::needsPainting(int ix, int iy, int bit);
++ bool needsPainting(int ix, int iy, int bit);
+
+ public:
+ /* Range of paper jet covers when head is at 0,0 */
+@@ -54,7 +54,7 @@
+ /* Range of paper jet needs to cover to get the entire image */
+ void getImageRange(Rect *dest);
+ Coord *getPreferredImageStart(Coord *start);
+- int Jet::getPreferredEnd();
++ int getPreferredEnd();
+ bool finished();
+ void setImageStart(Coord *imageStart);
+ void paint(int startX, int endX, int y, class LexmarkProtocol *protocol);
+diff -ru lm1100.1.0.2a~/LinkedList.h lm1100.1.0.2a/LinkedList.h
+--- lm1100.1.0.2a~/LinkedList.h 2006-12-02 18:48:16.000000000 +0100
++++ lm1100.1.0.2a/LinkedList.h 2006-12-02 18:49:54.000000000 +0100
+@@ -26,8 +26,8 @@
+ void *object;
+ LinkedList *next;
+
+- LinkedList::LinkedList();
+- LinkedList::LinkedList(void * object);
++ LinkedList();
++ LinkedList(void * object);
+ };
+
+ #endif
+diff -ru lm1100.1.0.2a~/Map.h lm1100.1.0.2a/Map.h
+--- lm1100.1.0.2a~/Map.h 2006-12-02 18:48:16.000000000 +0100
++++ lm1100.1.0.2a/Map.h 2006-12-02 18:49:54.000000000 +0100
+@@ -41,7 +41,7 @@
+ int height; /* height of map in cells */
+
+ Map(int width, int height, int cellSize);
+- Map::~Map();
++ ~Map();
+
+ void cacheLines(int start, int len);
+ void addAlgorithm(MapAlgorithm *algorithm);
+diff -ru lm1100.1.0.2a~/PPMRaw.h lm1100.1.0.2a/PPMRaw.h
+--- lm1100.1.0.2a~/PPMRaw.h 2006-12-02 18:48:16.000000000 +0100
++++ lm1100.1.0.2a/PPMRaw.h 2006-12-02 18:49:54.000000000 +0100
+@@ -32,7 +32,7 @@
+
+ public:
+ PPMRaw(Reader *reader,bool readMagic);
+- static void PPMRaw::readHeader(int *width, int *height, int *maxval, Reader *reader, bool readMagic);
++ static void readHeader(int *width, int *height, int *maxval, Reader *reader, bool readMagic);
+
+ virtual void getRGB(RGB *rgb, int x, int y);
+
+diff -ru lm1100.1.0.2a~/Rect.h lm1100.1.0.2a/Rect.h
+--- lm1100.1.0.2a~/Rect.h 2006-12-02 18:48:16.000000000 +0100
++++ lm1100.1.0.2a/Rect.h 2006-12-02 18:49:54.000000000 +0100
+@@ -23,8 +23,8 @@
+ class Rect
+ {
+ public:
+- Rect::Rect();
+- Rect::Rect(int x, int y, int width, int height);
++ Rect();
++ Rect(int x, int y, int width, int height);
+
+ int x,y,width,height;
+
diff --git a/net-print/lm1100/files/lm1100-1.0.2a-makefile.patch b/net-print/lm1100/files/lm1100-1.0.2a-makefile.patch
new file mode 100644
index 000000000000..b1f0a2ac4913
--- /dev/null
+++ b/net-print/lm1100/files/lm1100-1.0.2a-makefile.patch
@@ -0,0 +1,35 @@
+--- lm1100.1.0.2a~/Makefile 2001-02-26 01:40:16.000000000 +0100
++++ lm1100.1.0.2a/Makefile 2006-10-23 19:01:57.000000000 +0200
+@@ -7,17 +7,19 @@
+ VERSION=lm1100.1.0.2a
+ TARFILES = $(FILES:%=$(VERSION)/%)
+
+-CC = g++ -O2
++CXX?=g++
++CXXFLAGS?= -O2
++#CC = g++ -O2
+ #CC = g++ -g
+
+ lm1100: $(OBJS)
+- $(CC) -o lm1100 $(OBJS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o lm1100 $(OBJS) $(LIBS)
+
+ bufcat: SpongeWriter.o ThreadSafeCircleBuffer.o bufcat.o
+- $(CC) -o bufcat SpongeWriter.o ThreadSafeCircleBuffer.o bufcat.o -lpthread
++ $(CXX) $(CXXFLAGS) -o bufcat SpongeWriter.o ThreadSafeCircleBuffer.o bufcat.o -lpthread
+
+ leak: $(OBJS)
+- $(CC) -o lm1100 $(OBJS) $(LIBS) /usr/local/LeakTracer/LeakTracer.o
++ $(CXX) $(CXXFLAGS) -o lm1100 $(OBJS) $(LIBS) /usr/local/LeakTracer/LeakTracer.o
+
+ tarball: $(FILES)
+ rm $(VERSION);ln -s . $(VERSION);tar -cf - $(TARFILES) | gzip > $(VERSION).tar.gz
+@@ -27,7 +29,7 @@
+ rm *.o
+
+ %.o: %.cc
+- $(CC) $(DEFINES) -c $<
++ $(CXX) $(CXXFLAGS) $(DEFINES) -c $<
+
+ TAGS: $(SRCS)
+ etag $(SRCS)
diff --git a/net-print/lm1100/files/lm1100maint-firmware.patch b/net-print/lm1100/files/lm1100maint-firmware.patch
new file mode 100644
index 000000000000..5c3f4c92ea86
--- /dev/null
+++ b/net-print/lm1100/files/lm1100maint-firmware.patch
@@ -0,0 +1,14 @@
+diff -ur lm1100maint~/lm1100back lm1100maint/lm1100back
+--- lm1100maint~/lm1100back 2006-06-26 19:48:51.000000000 +0200
++++ lm1100maint/lm1100back 2006-06-26 19:50:41.000000000 +0200
+@@ -1,2 +1,2 @@
+ #!/bin/sh
+-dd if=/usr/share/lm1100maint/lexmarkback of=/dev/lp0
++dd if=/usr/share/lm1100/lexmarkback of=/dev/lp0
+diff -ur lm1100maint~/lm1100change lm1100maint/lm1100change
+--- lm1100maint~/lm1100change 2006-06-26 19:48:51.000000000 +0200
++++ lm1100maint/lm1100change 2006-06-26 19:50:55.000000000 +0200
+@@ -1,2 +1,2 @@
+ #!/bin/sh
+-dd if=/usr/share/lm1100maint/lexmarkchange of=/dev/lp0
++dd if=/usr/share/lm1100/lexmarkchange of=/dev/lp0