summaryrefslogtreecommitdiff
path: root/net-print/hplip/hplip-3.19.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-print/hplip/hplip-3.19.11.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-print/hplip/hplip-3.19.11.ebuild')
-rw-r--r--net-print/hplip/hplip-3.19.11.ebuild38
1 files changed, 20 insertions, 18 deletions
diff --git a/net-print/hplip/hplip-3.19.11.ebuild b/net-print/hplip/hplip-3.19.11.ebuild
index 83e3e5a46112..49cad9be3506 100644
--- a/net-print/hplip/hplip-3.19.11.ebuild
+++ b/net-print/hplip/hplip-3.19.11.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="threads(+),xml"
# 14 and 15 spit out a lot of warnings about subdirs
@@ -49,26 +49,28 @@ RDEPEND="
${COMMON_DEPEND}
app-text/ghostscript-gpl
!minimal? (
- >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
- fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
kernel_linux? ( virtual/udev )
- qt5? (
- >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}]
- libnotify? ( dev-python/notify2[${PYTHON_USEDEP}] )
- )
- scanner? (
- >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
- X? (
- || (
- kde? ( kde-misc/skanlite )
- media-gfx/xsane
- media-gfx/sane-frontends
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ qt5? (
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ X? (
+ || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ )
)
)
- )
+ ')
)
policykit? ( sys-auth/polkit )
"