summaryrefslogtreecommitdiff
path: root/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild')
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild
new file mode 100644
index 000000000000..39fcb8992631
--- /dev/null
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20190226.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils versionator
+
+MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="linuxprinting.org PPD files for postscript printers"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ eapply "${FILESDIR}/Makefile.in-4.0.20120117.patch"
+ rm db/source/PPD/Kyocera/ReadMe.htm || die # bug #559008
+ default
+}
+
+src_install() {
+ default
+ rm -v "${ED}"/usr/share/foomatic/xmlschema/{driver,option,printer,types}.xsd || die "Cannot remove duplicates"
+}