summaryrefslogtreecommitdiff
path: root/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild')
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
new file mode 100644
index 000000000000..831c507b34a3
--- /dev/null
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="linuxprinting.org PPD files for postscript printers"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ epatch "${FILESDIR}/Makefile.in-4.0.20120117.patch"
+ rm db/source/PPD/Kyocera/ReadMe.htm || die # bug #559008
+}
+
+src_install() {
+ default
+ rm -v "${ED}"/usr/share/foomatic/xmlschema/{driver,option,printer,types}.xsd || die "Cannot remove duplicates"
+}