summaryrefslogtreecommitdiff
path: root/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild')
-rw-r--r--net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild b/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..4f15dfb3ac98
--- /dev/null
+++ b/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils autotools
+
+DESCRIPTION="Dymo SDK for LabelWriter/LabelManager printers"
+HOMEPAGE="https://newellrubbermaid.secure.force.com/dymopkb"
+SRC_URI="http://download.dymo.com/Download%20Drivers/Linux/Download/${P}.tar.gz"
+
+S="${WORKDIR}/${P}.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test usb-modeswitch"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=net-print/cups-2.3.0"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+ usb-modeswitch? ( sys-apps/usb_modeswitch )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-cxxflags.patch
+ "${FILESDIR}"/port_to_newer_cups_headers.patch
+ "${FILESDIR}"/dymo-cups-drivers-1.4.0.5-flexible-tests.patch
+ "${FILESDIR}"/cups-2.3.0-headers.patch
+)
+
+DOCS=( AUTHORS README ChangeLog docs/SAMPLES )
+
+src_prepare() {
+ default
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc docs/*.{txt,rtf,ps,png}
+}
+
+src_test() {
+ # upstream tests are designed to be run AFTER make install, because they depend on final paths.
+ testroot="${T}/testroot"
+ mkdir -p "${testroot}"
+ emake install DESTDIR="${testroot}"
+ # -W filters is because CUPS tries really hard for secure filters: they must be root/root for the filter tests to pass
+ #chown root:root "${testroot}"/usr/libexec/cups/filter/{raster2dymolm,raster2dymolw} || die "failed to set ownership for tests"
+ # This will trigger the following warning repeatedly
+ #Bad permissions on cupsFilter file "..${testroot}/usr/libexec/cups/filter/raster2dymolm"
+ emake check CUPSTESTPPD_OPTS="-R ${testroot} -W filters"
+}