summaryrefslogtreecommitdiff
path: root/net-print/cnijfilter2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /net-print/cnijfilter2
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'net-print/cnijfilter2')
-rw-r--r--net-print/cnijfilter2/Manifest4
-rw-r--r--net-print/cnijfilter2/cnijfilter2-5.40.ebuild64
-rw-r--r--net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch20
3 files changed, 77 insertions, 11 deletions
diff --git a/net-print/cnijfilter2/Manifest b/net-print/cnijfilter2/Manifest
index eea873b2e45e..2ed06481c234 100644
--- a/net-print/cnijfilter2/Manifest
+++ b/net-print/cnijfilter2/Manifest
@@ -1,4 +1,6 @@
-AUX cnijfilter2-5.20-gentoo.patch 1775 BLAKE2B db93bfa9d09c2478ea7e6fa79cd38ef21b4743330853b31d22e2f9ba6923045a8b40170efdcfd72ea91384046d3b96c7ab74bf9699ef48e01644a336b0603fc5 SHA512 d79e611dacb2362ead277a593fe1082fce960c67f24af830e5b093ac4bcb641f9db6de84afa9be9b5495967a6826ddd5313fd76da507372945c5162e98736826
+AUX cnijfilter2-5.20-gentoo.patch 1535 BLAKE2B c3861e039d0ecce6f1940c1f998ce23ab2834f18a7394c82070e83d7de4d7860869775d5e017a8e26999f3798090bcffab699916263953afbc52a24f39b3bb23 SHA512 29458eabdfe3f7c66b47ddbd490c741b78a3cb9b375be1769e65d2240e732fc184005de226eed8985f77aa153c00c39463d9fce41ba79a439874ebb031acb70d
DIST cnijfilter2-source-5.20-1.tar.gz 466507 BLAKE2B 1ca96153350a157f56dfed691a04dcbe1e3ab5462b59c0cd919316a7c54a36bbeb34cf4205132f0aa3e5a23f89eb260c35c1a3ee14ea85bc36b9e3b67cd7e3f7 SHA512 60be49d34adf9a4d2cd8337cccb36eb8c078e9712bf8043c3552f1d83c3da307badfe34fc3683c99e3234da30f4ba82e0c4a0b48ea5f78f0d66db1408bd7d495
+DIST cnijfilter2-source-5.40-1.tar.gz 817298 BLAKE2B 1088eb19c70ed9133c38b8a6da9fbc26c42d6f077fda01678fb4485c2db21a17567fab8ab5c9565ece7ea13e5fac3f7c5842e984116d6c595e7a1f19092d3461 SHA512 bb4ce18864037fae9735fcb1b2c3198fe39f8abe0caa754e457e3cb0d03767742d82ff4fddf81451215395b23eea8207a880e238558e0ea2ac5c359186ecd859
EBUILD cnijfilter2-5.20.ebuild 1403 BLAKE2B 1daedead655b9573ea422a8374bf04449baed0d9f845fb64852f0a3515694d6a24cb799f83d98074553808b6e3cadeb273a4b54c1a743d079658c5f093f1cadf SHA512 e316d08d3e04b5bdc2b3281c4e2d983b8bb4d4a46b7b32b088fa65c370f613ec3a4a6d48252f620125974212b4c235d42316ef73c7748fed940ab44442d09027
+EBUILD cnijfilter2-5.40.ebuild 1515 BLAKE2B 5c7452ce92474cc403a1051b622e18ff257759bfd80b45c0e928ecf2a68e69a78eefa31ec60f29e1c4c9aa218dbab5141ccb1251a9fd46f171332dbf069975ae SHA512 0e75f8248fe1d14e2bede4e172e662492c7e2483c2dbebe66d1a8ba719df3b3c6da31f83dd2be7c71db98367a62f969a6a0ad1d7cf8ea68eb17bfdc4f6097171
MISC metadata.xml 339 BLAKE2B aa954d512a8d86489f00bcaf9f59d4427e95e095b42ef7946456db0c9037fcda08a9940e22df160871fcf1d19d8c06852b707934a904fa680ed06726fcd5c735 SHA512 a8976b24c12b154f9cdcd8a6f31d10f35a039a51141eda7aaea0fa6e9f7f9d405745f4910c6f56d44fac6ecde6bd927dc8a1e10f995279816f1bc551667dedd5
diff --git a/net-print/cnijfilter2/cnijfilter2-5.40.ebuild b/net-print/cnijfilter2/cnijfilter2-5.40.ebuild
new file mode 100644
index 000000000000..038cbf38f1bc
--- /dev/null
+++ b/net-print/cnijfilter2/cnijfilter2-5.40.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN}-source-${PV}-1"
+
+DESCRIPTION="IJ Printer Driver"
+HOMEPAGE="https://www.canon.it/"
+SRC_URI="http://gdlp01.c-wss.com/gds/3/0100008393/01/${MY_P}.tar.gz"
+
+LICENSE="Canon-IJ"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1
+ dev-libs/libxml2
+ net-print/cups"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-5.20-gentoo.patch )
+
+src_prepare() {
+ default
+ DIRS="cmdtocanonij2 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg"
+ LIBDIR=com/libs_bin$(usex amd64 64 32)
+ for d in ${DIRS}; do
+ mv "${d}"/configure.{in,ac} || die
+ done
+ echo "AC_INIT([${PN}], [${PV}])" >> configure.ac
+ echo "AM_INIT_AUTOMAKE" >> configure.ac
+ echo "AC_CONFIG_SUBDIRS([${DIRS}])" >> configure.ac
+ echo "AC_CONFIG_FILES([Makefile])" >> configure.ac
+ echo "AC_OUTPUT()" >> configure.ac
+ echo "SUBDIRS= ${DIRS}" >> Makefile.am
+ sed -i \
+ -e "/^CFLAGS/d" \
+ */configure.ac || die
+ eautoreconf
+ cd ${LIBDIR}
+ rm libcn*.so || die
+ ln -sf libcnbpcnclapicom2.so.5.0.0 libcnbpcnclapicom2.so || die
+ ln -sf libcnbpnet20.so.1.0.0 libcnbpnet20.so || die
+ ln -sf libcnbpnet30.so.1.0.0 libcnbpnet30.so || die
+ ln -sf libcnnet2.so.1.2.4 libcnnet2.so || die
+
+ cd -
+}
+
+src_configure() {
+ LDFLAGS="-L"${S}"/${LIBDIR}" econf --enable-progpath="${EPREFIX}/usr/bin"
+}
+
+src_install() {
+ default
+ insinto /usr/share/ppd/cupsfilters
+ doins ppd/*ppd
+ dolib.so ${LIBDIR}/*
+}
diff --git a/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch b/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
index 80c7361cb1a1..be941790b995 100644
--- a/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
+++ b/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
@@ -1,13 +1,13 @@
---- cnijfilter2-source-5.20-1/cmdtocanonij2/filter/Makefile.am.old 2018-01-14 18:14:20.645473030 +0100
-+++ cnijfilter2-source-5.20-1/cmdtocanonij2/filter/Makefile.am 2018-01-14 18:14:36.078219959 +0100
+--- a/cmdtocanonij2/filter/Makefile.am.old 2018-01-14 18:14:20.645473030 +0100
++++ b/cmdtocanonij2/filter/Makefile.am 2018-01-14 18:14:36.078219959 +0100
@@ -1,4 +1,4 @@
-filterdir=$(libdir)/cups/filter
+filterdir=$(libexecdir)/cups/filter
filter_PROGRAMS= cmdtocanonij2
---- cnijfilter2-source-5.20-1/cnijbe2/src/Makefile.am.old 2018-01-14 19:25:48.823470121 +0100
-+++ cnijfilter2-source-5.20-1/cnijbe2/src/Makefile.am 2018-01-14 19:25:59.316275741 +0100
+--- a/cnijbe2/src/Makefile.am.old 2018-01-14 19:25:48.823470121 +0100
++++ b/cnijbe2/src/Makefile.am 2018-01-14 19:25:59.316275741 +0100
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
@@ -16,16 +16,16 @@
backend_bin_PROGRAMS = cnijbe2
transform =
---- cnijfilter2-source-5.20-1/rastertocanonij/src/Makefile.am.old 2018-01-14 21:31:33.053307218 +0100
-+++ cnijfilter2-source-5.20-1/rastertocanonij/src/Makefile.am 2018-01-14 21:31:41.106166479 +0100
+--- a/rastertocanonij/src/Makefile.am.old 2018-01-14 21:31:33.053307218 +0100
++++ b/rastertocanonij/src/Makefile.am 2018-01-14 21:31:41.106166479 +0100
@@ -1,4 +1,4 @@
-filterdir=$(libdir)/cups/filter
+filterdir=$(libexecdir)/cups/filter
filter_PROGRAMS= rastertocanonij
---- cnijfilter2-source-5.20-1/tocanonij/src/Makefile.am.old 2018-01-15 22:38:14.236460663 +0100
-+++ cnijfilter2-source-5.20-1/tocanonij/src/Makefile.am 2018-01-15 22:38:39.184018933 +0100
+--- a/tocanonij/src/Makefile.am.old 2018-01-15 22:38:14.236460663 +0100
++++ b/tocanonij/src/Makefile.am 2018-01-15 22:38:39.184018933 +0100
@@ -1,7 +1,8 @@
INCLUDES = \
-I$(top_srcdir)/include/cncl
@@ -36,8 +36,8 @@
tocanonij_SOURCES= \
main.c
---- cnijfilter2-source-5.20-1/tocnpwg/src/Makefile.am.old 2018-01-15 22:42:43.759703863 +0100
-+++ cnijfilter2-source-5.20-1/tocnpwg/src/Makefile.am 2018-01-15 22:43:10.442232986 +0100
+--- a/tocnpwg/src/Makefile.am.old 2018-01-15 22:42:43.759703863 +0100
++++ b/tocnpwg/src/Makefile.am 2018-01-15 22:43:10.442232986 +0100
@@ -2,7 +2,8 @@
INCLUDES = \
@XML_2_CFLAGS@