summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /net-p2p
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin9918 -> 10091 bytes
-rw-r--r--net-p2p/cpuminer-opt/Manifest5
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild47
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild47
-rw-r--r--net-p2p/cpuminer-opt/files/cpuminer-opt.service27
-rw-r--r--net-p2p/cpuminer-opt/metadata.xml11
-rw-r--r--net-p2p/go-ethereum/Manifest2
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild42
8 files changed, 181 insertions, 0 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index 455bf31920d6..17e1053fa343 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
new file mode 100644
index 000000000000..dc7c788053f4
--- /dev/null
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -0,0 +1,5 @@
+AUX cpuminer-opt.service 690 BLAKE2B f95dff31fb5ff12da8b8ae282bba4c0fd15b5c0aa7e0f2b87f94a901a8e15ea5c81e6704fe5e81681383a3d82c41516174c4cae3a6dc59c9d2af618197f32189 SHA512 d175754246d61d08d615af52c3499d67e4d8c6a5166f07ea4fd646f3000ca7afed99f9b436785c50141a86b5faf017be4b2d1d5d2f9e3921a6171e4223be9b4c
+DIST cpuminer-opt-3.7.7.tar.gz 1602520 BLAKE2B 059afdbd90ff062c698432d352fbb9f32807219a24659f5e27990a32b791d868147cf6fa027dff60d2e16d5f43b36b826dbabdc971e4dae4e1473aaf8795b222 SHA512 85989257ef8ee945000621598f6a9c4ed1b8099c57902d570db3038617b787254a925865567541d75e4433aaff564ffc82bd659f645ca812f809602bef8bc7c7
+EBUILD cpuminer-opt-3.7.7.ebuild 1075 BLAKE2B 10de22358a2bf8896da6db2151e8f5984d531fbaca07fe1032ee11785e3f19b612113ca0ae7324e1b1811e8ec465964eac3aa37e1b7892056a511bda75a2aaac SHA512 083f2279b51a96509cc585f234d49f3a15b6f441ac383708a94caeddc00b10485fcc5c3a09cd8b701813f7a0186639436bd6c49edefb4f03a1d86dee2a2b3863
+EBUILD cpuminer-opt-9999.ebuild 1060 BLAKE2B 63e3b702153f5961a892904b5146f8367d30a663efc028222738e745bf0e45c9016b5d645f41219fb3efcb485921c46ea9a8c1e97c454dfa796929f3bf19b3b1 SHA512 a4ccb1664da6b692b53b7a76c127e8f3bf3b6f8e0772b9c4ba1b430b7a18d9d374eec58a53f93fc23e78ffa4b36fbf5e8486cb1c46701e1538a054085cdcbe73
+MISC metadata.xml 333 BLAKE2B f7851fe0d55d729c75e3934fa32ab578c57d3dfc4a1634cc8dcca655f0d4ab1a6bb56d0b9c347dedb6cedf3d5a5a7a1bb9662856733970b1cc8db288c26be4a2 SHA512 770d39605bb1afa7d7643b4fc8f295e449f90175ae0d31c8a5023bfc9ba233c9e80ebf1dfbf81c4b86af8dc1d66bc336a4464748f162119b35fcb695cd54e656
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild
new file mode 100644
index 000000000000..3ff3d3b75188
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ use cpu_flags_x86_avx2 && append-cflags "-DFOUR_WAY"
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
new file mode 100644
index 000000000000..9d637b9169d3
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ use cpu_flags_x86_avx2 && append-cflags "-DFOUR_WAY"
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/files/cpuminer-opt.service b/net-p2p/cpuminer-opt/files/cpuminer-opt.service
new file mode 100644
index 000000000000..90ee849c5bac
--- /dev/null
+++ b/net-p2p/cpuminer-opt/files/cpuminer-opt.service
@@ -0,0 +1,27 @@
+[Unit]
+Description=CPU mining daemon for cryptocurrencies
+After=network-online.target
+AssertFileNotEmpty=/etc/cpuminer-opt/cpuminer-conf.json
+
+[Service]
+ExecStart=/usr/bin/cpuminer --syslog --config=/etc/cpuminer-opt/cpuminer-conf.json
+DynamicUser=true
+CPUSchedulingPolicy=idle
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=strict
+NoNewPrivileges=true
+PrivateDevices=true
+CapabilityBoundingSet=
+MemoryDenyWriteExecute=true
+ProtectKernelModules=true
+ProtectKernelTunables=true
+ProtectControlGroups=true
+RestrictRealtime=true
+RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX
+RestrictNamespaces=true
+PrivateUsers=true
+ConfigurationDirectory=cpuminer-opt
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-p2p/cpuminer-opt/metadata.xml b/net-p2p/cpuminer-opt/metadata.xml
new file mode 100644
index 000000000000..b95044df0235
--- /dev/null
+++ b/net-p2p/cpuminer-opt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">JayDDee/cpuminer-opt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 607e6d45c2c3..3dc8fe4d058f 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1,3 +1,5 @@
DIST go-ethereum-1.7.2.tar.gz 7037907 BLAKE2B eb1e358e42c743a931995e7ee46dc2441356159fc9095e8a886cc6a0495cb2d2e77ee7df4c6dd98bc790397819fc43cdedba6cf28de1e4f3dcdc4dd71106f8e5 SHA512 7bc5957f1523fa5ec67650c4305633aa4c6098a243ef415f9ef56a4e4763eb2ef9f69514ed15810fcdb75f11e87cbd27c4f2af802c32a03be91b37a7b08ea520
+DIST go-ethereum-1.7.3.tar.gz 8188445 BLAKE2B abfa7fff970ea740376e05a56c51a83ba62853b68fd1de1a7161192da294558ea2939427119d00aadcb9e00b8b487e1acfae058e0c5ab6dbe3531e4db0b446cb SHA512 c50391f84b64c924c56d8d052a5c910f94869d86b080cd9b3355a48e094e7f5d4a05a631a57a74619b677067be5da21d6018d18a81bd014bceed43d3626cb017
EBUILD go-ethereum-1.7.2.ebuild 844 BLAKE2B 1b3b946a7bbdad1b891caecbd679ae4136e7ab78a2dcdc79b9922a27d47e6afb421d58f4eae3db1f94e3c7c309503c08a8cc6bacdcd1efcaf05f7777a3be5ffe SHA512 1c62060bbbfd023a6b058192edb08f5b20be10e8727ff322b1c98f4abb2c1ca6cb9f240a5667e5674beee44193d5b011f11e0edffe895b7ed763a2561bca13e4
+EBUILD go-ethereum-1.7.3.ebuild 865 BLAKE2B efb324f64db492900fb57808516caf3285b3f67c8513fb1aec24c8bf10bdd7ed9b4dfa5e04bda732b2c6b00461895c1321f7be9d7ed42796891fe6839241d06f SHA512 60cf846d028395cf438996dec9b7535be060dfd33aca9f773e75ffe455e1affc88d4df95f114780448fe9f4a0f1069c9afae0d7a0cdf3822ae9c3dfc92082bbf
MISC metadata.xml 619 BLAKE2B c425c01f78c66b3c6b0bb4109cad466a9fd5a53ff982aa01c19609836a309e2ebea40c14a5cf850b32f2e3c8f632fca667c864af6e64bfe1738548442464e3bc SHA512 4cd641e4ac75451298d45e0fc37f93b5527d2aa567f1350cd48c02f7a0fd203f4c394e089fddb14ffb1365de98dd31b813ce7c268096054e01e1efbab1310419
diff --git a/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
new file mode 100644
index 000000000000..a7fce9166ec3
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-base
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ if use devtools; then
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ dobin build/bin/swarm
+ dobin build/bin/wnode
+ fi
+}