summaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-p2p/qbittorrent
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Manifest2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.3.0.1.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index a4aeaf38673d..ddfc58ccf75d 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,4 +1,6 @@
DIST qbittorrent-4.2.5.tar.gz 7961612 BLAKE2B 61d2f2154a291a6d1ddab7d4775d4ac4d19f471dceb783cb7933015ed9159afdca4075f429891dbbd7249f09d910ef643d27da4c4b7307adbf29354222265027 SHA512 8808029bdb3a1638fcf792e92c36bd39889dbc2ceb26c8d45ff17b086bd076f0b3a8ed78dd6a1e3debd32e5b0ce212eea194ec601210ae29093cfb567eb4ca0f
+DIST qbittorrent-4.3.0.1.tar.gz 7752986 BLAKE2B c4541a5e93a9674dcaee02ef8f7d0335644e5530116070a4fac74952ab8a4ebaec2ae03b95f001c15c491d5f6963e6d305cef2392bd61bd615278a34a0ebb121 SHA512 b49ddafe8c01fa4dae4ee30130237456aee3eba2cdb666c4939d84f44d6b523c5ed7aba1174fad6d168db4de11210d2b97c0d304f5ee653cbf1c8ca2dd96afe3
EBUILD qbittorrent-4.2.5-r2.ebuild 1373 BLAKE2B f86d98fbe0308c890231bb88b9016388718b651ac65c2447e6d622841e24e5d86e9d0f8fd74aed3b30c32b97595b324ee656c032cf85ca32f2b965ee42f6c894 SHA512 8620cbe83d0bfe5f5adc58f8417dfc2e7d00a914e427fa763430d9ce8a03e2f06be7a6bd9f049022b1cf3c9673f20d0a6b138cc6c52d26ba95e745ee8df43a94
+EBUILD qbittorrent-4.3.0.1.ebuild 1375 BLAKE2B b4d94d84237fe95c359508fbd9c903bf295bf3657cf9c62c22bcf929d6ea65d023cf552c8ffafbbde6b32088e19a77fe17601b863f416b95b253af3059bfc7d3 SHA512 6306571d1508d1550f91fe8793032b9de8248e900c9ea7daf9fdfdeb1750d0e53ac1042bec201890aa59d0d6b0aaf1f4e3d1f29df14493910a595c4f4451c070
EBUILD qbittorrent-9999.ebuild 1373 BLAKE2B f86d98fbe0308c890231bb88b9016388718b651ac65c2447e6d622841e24e5d86e9d0f8fd74aed3b30c32b97595b324ee656c032cf85ca32f2b965ee42f6c894 SHA512 8620cbe83d0bfe5f5adc58f8417dfc2e7d00a914e427fa763430d9ce8a03e2f06be7a6bd9f049022b1cf3c9673f20d0a6b138cc6c52d26ba95e745ee8df43a94
MISC metadata.xml 452 BLAKE2B 80b94ef467eaad04be0f17b8d15d1af20a2d09f27825a2c315445fb82c33bbcb35ca5c81e40b7ff21a0496b03f030a2d30b92fd2b39caafce47b7295d4daf98d SHA512 bce9d619f6c591237e412393678d54db4fe55fbd3ab52d191860bc97c7245e199c9630c8b76ea885fe195b486231b65906dc099361ccff59fe0adca08059c85e
diff --git a/net-p2p/qbittorrent/qbittorrent-4.3.0.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.3.0.1.ebuild
new file mode 100644
index 000000000000..15913a17fc03
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.3.0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.0:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}