summaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent/qbittorrent-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-19 15:53:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-19 15:53:17 +0100
commitf827ced0163cc11d6d35e2d4e2c8a7ab3fd6482a (patch)
tree213f8697ab84110f617f44fcac7687e137821060 /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parentd99752d3d5e12a0fc38778cb734bc68bbe2ed3bb (diff)
gentoo auto-resync : 19:10:2023 - 15:53:17
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index eeba63e2c817..9ff0a380b472 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus +gui qt6 test webui"
+IUSE="+dbus +gui qt6 test webui systemd"
RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( gui webui )"
@@ -47,7 +47,9 @@ RDEPEND="
dev-qt/qtnetwork:5[ssl]
dev-qt/qtsql:5[sqlite]
dev-qt/qtxml:5
- )"
+ )
+ acct-group/qbittorrent
+ acct-user/qbittorrent"
DEPEND="
${RDEPEND}
dev-libs/boost
@@ -98,6 +100,9 @@ src_configure() {
mycmakeargs+=(
-DGUI=OFF
-DDBUS=OFF
+ )
+
+ use systemd && mycmakeargs+=(
# The systemd service calls qbittorrent-nox, which is only
# installed when GUI=OFF.
-DSYSTEMD=ON
@@ -127,4 +132,7 @@ src_test() {
src_install() {
multibuild_foreach_variant cmake_src_install
einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
}