summaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent/qbittorrent-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
commita4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (patch)
tree1c6cf78322fbf3379d5b7e4f4b836a42c5fddd19 /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parenta4e37a9aeeef82eba5858dbc609f65b838b0f836 (diff)
gentoo auto-resync : 06:10:2022 - 01:20:42
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index dd26453408e2..c6292efff901 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -57,15 +57,9 @@ src_prepare() {
src_configure() {
multibuild_src_configure() {
local mycmakeargs=(
- -DDBUS=$(usex dbus)
-
# musl lacks execinfo.h
-DSTACKTRACE=$(usex !elibc_musl)
- # We always want to install unit files
- -DSYSTEMD=ON
- -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
-
# More verbose build logs are preferable for bug reports
-DVERBOSE_CONFIGURE=ON
@@ -80,9 +74,20 @@ src_configure() {
if [[ ${MULTIBUILD_VARIANT} == gui ]] ; then
# We do this in multibuild, see bug #839531 for why.
# Fedora has to do the same thing.
- mycmakeargs+=( -DGUI=ON )
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
else
- mycmakeargs+=( -DGUI=OFF )
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
fi
cmake_src_configure
@@ -106,11 +111,5 @@ src_test() {
src_install() {
multibuild_foreach_variant cmake_src_install
-
- if ! use webui ; then
- # No || die deliberately as it doesn't always exist
- rm "${D}/$(systemd_get_systemunitdir)"/qbittorrent-nox*.service
- fi
-
einstalldocs
}