summaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent/qbittorrent-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 6453f2dac227..cc5d592f00f4 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,19 +3,19 @@
EAPI=6
-inherit cmake-utils gnome2-utils xdg-utils
+inherit gnome2-utils xdg-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="https://www.qbittorrent.org/"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
else
- MY_P=${P/_}
- SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
- S=${WORKDIR}/${MY_P}
+ S="${WORKDIR}/qBittorrent-release-${PV}"
fi
LICENSE="GPL-2"
@@ -33,6 +33,7 @@ RDEPEND="
sys-libs/zlib
dbus? ( dev-qt/qtdbus:5 )
X? (
+ dev-libs/geoip
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
@@ -47,13 +48,16 @@ DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
# may be changed again.
src_configure() {
- local mycmakeargs=(
- -DSYSTEM_QTSINGLEAPPLICATION=ON
- -DDBUS=$(usex dbus)
- -DGUI=$(usex X)
- -DWEBUI=$(usex webui)
- )
- cmake-utils_src_configure
+ econf --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
}
pkg_postinst() {