summaryrefslogtreecommitdiff
path: root/net-p2p/ncdc/ncdc-1.23.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-13 21:28:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-13 21:28:20 +0000
commitb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (patch)
treeceff6a3b47b9258682735a5595c9ee8a0427a445 /net-p2p/ncdc/ncdc-1.23.1.ebuild
parent50098d976449286058396cebad0087e28f771b90 (diff)
gentoo auto-resync : 13:12:2022 - 21:28:20
Diffstat (limited to 'net-p2p/ncdc/ncdc-1.23.1.ebuild')
-rw-r--r--net-p2p/ncdc/ncdc-1.23.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/ncdc/ncdc-1.23.1.ebuild b/net-p2p/ncdc/ncdc-1.23.1.ebuild
new file mode 100644
index 000000000000..8a4f76ec1de9
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.23.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="Lightweight direct connect client with a friendly ncurses interface"
+HOMEPAGE="https://dev.yorhel.nl/ncdc"
+SRC_URI="
+ https://dev.yorhel.nl/download/${P}.tar.gz
+ verify-sig? ( https://dev.yorhel.nl/download/${P}.tar.gz.asc )
+"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="geoip"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.74:2
+ >=net-libs/gnutls-3:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib
+ geoip? ( dev-libs/libmaxminddb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/makeheaders
+ virtual/pkgconfig
+ dev-lang/perl
+ verify-sig? ( sec-keys/openpgp-keys-yorhel )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/yoranheling.asc
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with geoip)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}