summaryrefslogtreecommitdiff
path: root/net-p2p/kubo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-11 18:08:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-11 18:08:11 +0000
commit23650861e24563ddcf10919ab5b1912676c3ff0c (patch)
tree0853606be5f409f8f1859eb33652d0c8c1e62623 /net-p2p/kubo
parent44a6f923079d51164af67c7bc3f3e0db24658088 (diff)
gentoo auto-resync : 11:03:2023 - 18:08:11
Diffstat (limited to 'net-p2p/kubo')
-rw-r--r--net-p2p/kubo/Manifest2
-rw-r--r--net-p2p/kubo/kubo-0.18.1.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index edef64b4ba1c..af808da8b0ea 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -3,5 +3,7 @@ AUX ipfs.confd 30 BLAKE2B 7ecaa40f2a4097690f9d8091da5891e0bbfb0f298bed4a59769c8d
AUX ipfs.init 464 BLAKE2B 553288784ba3df93037f640663d7ed3539f9a55e72ee9a36a9708e5b3f44e1dadff287fee989301b4ddf6fd3a88dbd1cf119386337c14523b9dadb91bdb1833d SHA512 2bc48d759b0dd4936d749aa0a442e39fdc862b5d5283269d4300cf0a5e3dc1bd0111a911d46d7a22dd7fa8023b22a148fbc371fc5bb37ce97912860b068caafc
AUX ipfs.service 372 BLAKE2B 8989cc474ab46309dda6d167fb89476b01d10e07374d53c480a7ee345f13827e25ca19d84b0a3974e45c5d9a0c78abdfd7be262bff48f427aedaac2a9c4094a8 SHA512 35d5edda83bd296f92ffe3ee61f2608eb9ec464225e32ca52582d8e8fe699466c9b412ed224ff44e36e34d3d41a618d50082dd677feeaba53429d3a6913a869a
DIST kubo-0.15.0.tar.gz 13318096 BLAKE2B 92a97eea130d24065c5d8a60ee7eb9b2bd3afba94596c0b538b04970277df11bf11f1cfc8399b303cea58cd249a86f956174d6544e6b6a94b34722ecdd20671a SHA512 26c1945c4ce641953e72a8f08802aa5acdd6c39fee3c1306bec0613a36b3d1ad79e23f7531427631848a6952ed950d27cd6a09f18352043bc145669b491843e6
+DIST kubo-0.18.1.tar.gz 13582874 BLAKE2B bc5ae67a476e796d774b47d29a5338cf2d1f1029197177bc69a36be255502bf12b45a8c6f5c4009ea100c749d73addc2195ce308e52883c8a36fecd08df26850 SHA512 eb6245abfef2079980f67f6a2dffad36346d06587df754d8477eeeda96464d9fa1428bb5d9ae628cca3ffa6a52c66c20e980c5a20ade389c1089aba947df6365
EBUILD kubo-0.15.0.ebuild 1771 BLAKE2B 9e73805889ff6404d82e59491c70b6f8cc04b3398d25de6b5e03780cb07125c097d8ce701e463a56bd8139bd219d9b315bc4f181c2a4586dc133b2ecc6c3d483 SHA512 97f722facbf10e1a7928f55714439af111a2f3e9d70b4f19fc916689cc1e1c515a5fe4c075aa54888e53e68fbacfe0f5a7878d859e3594d38766f254f4b14aac
+EBUILD kubo-0.18.1.ebuild 1771 BLAKE2B bce5adfd7fc1435347c357d8469846bd49d203ab102c967e958736254dbef46596f9b51d937c74e5616cd8b097bd4acd229ddebaf74b87d822e984af804e80c3 SHA512 c481f6758f069ca71346bfdbf0f66eac25a02acbeaf5597d31abbedf0c4288d56ae2639a70e1b202a501d14be40548827a1df94d7305caeea6d90551917c757a
MISC metadata.xml 596 BLAKE2B 68c5576e325ef2e0a6954047b8784427ca8b1d038c4b7fc7a7f2082e2682dbb8b807083251c9e5eca927d070d21b1f5ee9f96e2cb2437a9f5934bdc46f139fb6 SHA512 2d41af83abc0527e9031f8bec8d471dc7d163714bb42b9d7f65c943993e7d554207a5fb85ad96ae94c7876a74e2b3c8dba6a8f70e4f1bbb5a785bb98624233a9
diff --git a/net-p2p/kubo/kubo-0.18.1.ebuild b/net-p2p/kubo/kubo-0.18.1.ebuild
new file mode 100644
index 000000000000..6cd5d94e6814
--- /dev/null
+++ b/net-p2p/kubo/kubo-0.18.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/ https://github.com/ipfs/kubo/"
+SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-lang/go"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
+
+S="${WORKDIR}"
+
+src_compile() {
+ local mygoargs
+ mygoargs=(
+ -tags release
+ )
+
+ ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
+ ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
+
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
+}
+
+src_test() {
+ ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
+}
+
+src_install() {
+ dobin ipfs
+ dobin ipfswatch
+ newbashcomp ipfs-completion.bash ipfs
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ keepdir /var/log/ipfs
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+
+ # See https://bugs.gentoo.org/838238
+ ewarn 'In case kubo CPU usage is too high run the next workaround'
+ ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
+ ewarn 'Be aware that this will make your node less visible to other peers'
+}