summaryrefslogtreecommitdiff
path: root/net-p2p/go-ipfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-p2p/go-ipfs
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-p2p/go-ipfs')
-rw-r--r--net-p2p/go-ipfs/Manifest2
-rw-r--r--net-p2p/go-ipfs/go-ipfs-0.13.0.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-p2p/go-ipfs/Manifest b/net-p2p/go-ipfs/Manifest
index b431af5ada33..95b4544bd157 100644
--- a/net-p2p/go-ipfs/Manifest
+++ b/net-p2p/go-ipfs/Manifest
@@ -5,5 +5,7 @@ AUX ipfs.init 464 BLAKE2B 553288784ba3df93037f640663d7ed3539f9a55e72ee9a36a9708e
AUX ipfs.service 372 BLAKE2B 8989cc474ab46309dda6d167fb89476b01d10e07374d53c480a7ee345f13827e25ca19d84b0a3974e45c5d9a0c78abdfd7be262bff48f427aedaac2a9c4094a8 SHA512 35d5edda83bd296f92ffe3ee61f2608eb9ec464225e32ca52582d8e8fe699466c9b412ed224ff44e36e34d3d41a618d50082dd677feeaba53429d3a6913a869a
DIST go-ipfs-0.12.2-deps.tar.xz 368885112 BLAKE2B a77bd1518f1c80369a2d7f4ed3c3a19e0294f662910b588c203bcfa630709ef82e42a622a9a6a8b4e218b1566a446eb80ae0fdbd98232bd2aba6c76ed8a828ec SHA512 1268e9727af7a7c856547bd8cce9a9fe5b58db1a6966c2aeb0923632dc96fee16c354261922d7132f791bcc3c2601728831e2e2ec29d9b7d2d8ea60903eafe50
DIST go-ipfs-0.12.2.tar.gz 2112884 BLAKE2B fe6883443eaa55764beffb5b8726678615f1246d41924ca6eddaae0e67d241f85f24d9b9264eaae9a211d8f74009bc30dda2a35734ea38645736e4fe21212bc9 SHA512 a268618d66e5e82c89362e0273c0741a56d13ee95e1f545a0b55fa5a7bd719b0e678c7c6cb7dc268892f992156a1fff2f537688de589d7c05b8b48e9c90b94f1
+DIST go-ipfs-0.13.0.tar.gz 13474994 BLAKE2B 068484941ae831f9484e5c8a95614be611dfc6e3e0cd6b3f55e17b3339cbe0f4d76d4eaef2b95a7973028e1910abc92fe54acecd72d949f9a3e4a7be66a6f89c SHA512 2513076c193ec0e2a8ecaef8b6d2de5152ef9f5d1e7140735eb405f325d8b31968d2166dbbea28660b03e3458e44d25fc9f970c753ad9d0f56a3970bca7d9365
EBUILD go-ipfs-0.12.2.ebuild 1802 BLAKE2B e5de2f9e21364c3110c7491e04acb77ce1b3943ccb385b2efaf1369ae3a762d575bb68595f19862ef648017e78e5680ccb5c52f8601bf70f940279dda8f81cf6 SHA512 0485ca99686707e69ea3b746dda0a2dd3e25ce1f23b06b9dcd4b4aacefbff42db23ff612a1cf23f7741682d57253d75ffdc02902b19f17d53f446c7d933970c0
+EBUILD go-ipfs-0.13.0.ebuild 1727 BLAKE2B 0b61cb12d8cf1861dbf445354dffe901cd78c95fdc23e41ddc22d3283dd1438e8be0ccec144df16a256330e2ebf8dcb090f716ddf397ebf800fad61c21667a73 SHA512 b039e2d78b4ae3bf4dc798da4d9d283fa9e19dda9cb02d59cafaffa14d5b43d89d2bb6bbcffa4abaeafad3ec8cedb8f20123e66762d6eb0b3c80591b7b8234bd
MISC metadata.xml 522 BLAKE2B ac5e77995f9ba40ebd7fc6a23d7785ebb6abba433b84ea2ed99662fe8b63e197c58ff419345dcf9c2c9e466db0a2d0e92feb6d81dfffc4773efa322f2f5a957c SHA512 b1902465fb0f8c15f4d65fa8d4fd5b8deba2dba6cf9ca632e729a18921931259e135055d313468a04bb5ddc648616aa776c398df0b01431111ef46be9dbe3837
diff --git a/net-p2p/go-ipfs/go-ipfs-0.13.0.ebuild b/net-p2p/go-ipfs/go-ipfs-0.13.0.ebuild
new file mode 100644
index 000000000000..3418b0d7a9b5
--- /dev/null
+++ b/net-p2p/go-ipfs/go-ipfs-0.13.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/"
+SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/${PN}-source.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
+
+S="${WORKDIR}"
+
+src_compile() {
+ default
+
+ local mygoargs
+ mygoargs=(
+ -tags release
+ )
+
+ go build "${mygoargs[@]}" -o ipfs ./cmd/ipfs || die
+ go build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch || die
+
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
+}
+
+src_test() {
+ go test ./cmd/ipfs/... ./cmd/ipfswatch/... || die
+}
+
+src_install() {
+ dobin ipfs
+ dobin ipfswatch
+ newbashcomp ipfs-completion.bash ipfs
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ keepdir /var/log/ipfs
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+
+ # See https://bugs.gentoo.org/838238
+ ewarn 'In case go-ipfs CPU usage is too high run the next workaround'
+ ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower"'
+ ewarn 'Be aware that this will make your node less visible to other peers'
+}