summaryrefslogtreecommitdiff
path: root/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild')
-rw-r--r--net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..1e2ab6041d0d
--- /dev/null
+++ b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Tool for generating eDonkey2000 links"
+HOMEPAGE="http://ed2k-tools.sourceforge.net/ed2k_hash.shtml"
+RESTRICT="mirror"
+SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="" # fltk support is broken, bug #359643
+
+DEPEND=""
+RDEPEND=""
+#DEPEND="fltk? ( x11-libs/fltk:1 )"
+
+PATCHES=( "${FILESDIR}/ed2k_64bit.patch" )
+
+src_configure() {
+# if use fltk; then
+# append-ldflags "$(fltk-config --ldflags)"
+# export CPPFLAGS="$(fltk-config --cxxflags)"
+# else
+ export ac_cv_lib_fltk_main='no'
+# fi
+
+ econf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" mydocdir=/usr/share/doc/${PF}/html
+ einstalldocs
+}