summaryrefslogtreecommitdiff
path: root/net-p2p/deluge/deluge-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-p2p/deluge/deluge-9999.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-p2p/deluge/deluge-9999.ebuild')
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index be0397a7f781..f432594a17df 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_SINGLE_IMPL=1
inherit xdg distutils-r1 systemd
@@ -27,18 +27,16 @@ REQUIRED_USE="
sound? ( gtk )
"
-# Note: if/when Deluge supports newer libtorrent-rasterbar >= 2, please
-# move the dependency *outside* of gen_cond_dep and use PYTHON_SINGLE_USEDEP
-# instead. It doesn't seem like Deluge supports >= 2 right now.
DEPEND="
+ net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
- <net-libs/libtorrent-rasterbar-2.0.0[python,${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
')
dev-util/intltool
acct-group/deluge
acct-user/deluge"
RDEPEND="
+ net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
@@ -50,7 +48,6 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
>=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
- <net-libs/libtorrent-rasterbar-2.0.0[python,${PYTHON_USEDEP}]
geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
gtk? (
sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
@@ -64,9 +61,6 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.0.3-setup.py.patch"
"${FILESDIR}/${PN}-2.0.3-UI-status.patch"
- "${FILESDIR}/${PN}-2.0.3-gettext.patch"
- "${FILESDIR}/${P}-fix-pickle.patch"
- "${FILESDIR}/${P}-log.patch"
)
python_prepare_all() {