summaryrefslogtreecommitdiff
path: root/net-p2p/dbhub/dbhub-0.451-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /net-p2p/dbhub/dbhub-0.451-r1.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'net-p2p/dbhub/dbhub-0.451-r1.ebuild')
-rw-r--r--net-p2p/dbhub/dbhub-0.451-r1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-p2p/dbhub/dbhub-0.451-r1.ebuild b/net-p2p/dbhub/dbhub-0.451-r1.ebuild
index 7b53906e3d64..167df3c1edba 100644
--- a/net-p2p/dbhub/dbhub-0.451-r1.ebuild
+++ b/net-p2p/dbhub/dbhub-0.451-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=6
+inherit autotools
DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
HOMEPAGE="http://www.dbhub.org"
@@ -18,10 +18,14 @@ DEPEND="perl? ( dev-lang/perl )
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-gentoo.patch"
+ "${FILESDIR}/${PN}-no-dynaloader.patch"
+ "${FILESDIR}/${PN}-fix-buffer-overflows.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-gentoo.patch \
- "${FILESDIR}"/${PN}-no-dynaloader.patch \
- "${FILESDIR}"/${PN}-fix-buffer-overflows.patch
+ default
eautoreconf
}
@@ -32,7 +36,3 @@ src_configure() {
$(use_enable switch_user) \
$(use_enable debug)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}