summaryrefslogtreecommitdiff
path: root/net-p2p/bittornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /net-p2p/bittornado
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'net-p2p/bittornado')
-rw-r--r--net-p2p/bittornado/Manifest1
-rw-r--r--net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-p2p/bittornado/Manifest b/net-p2p/bittornado/Manifest
index e556d72fdf6d..e78d8676a3ac 100644
--- a/net-p2p/bittornado/Manifest
+++ b/net-p2p/bittornado/Manifest
@@ -2,4 +2,5 @@ AUX bttrack.conf 613 BLAKE2B ad791caf43fc5cf0e22f8fd01acab3d2f93feb827d64e07a1d6
AUX bttrack.rc 519 BLAKE2B 829b1a4cdb29bae41e25e832d7383ea4fda3ec2473d6d9bebc2738f126c9c95a937cbce0473bf5cf3a049b75e00a0301c3d8b1179c8c46db5f327e467977d9bc SHA512 74255a6dae0d5b1b5809dd6b7b792bb1f681d9c002dd64c0b633e4c903af8748922abe4521d0e52f23ad2d1f12066bf6a2eec1ad8112251e081f07002609eae0
DIST BitTornado-0.4.1_p20160925.tar.gz 164352 BLAKE2B 34cebe27ab0cb18a960ef830311ffa47f2064c83768a9a011dcd9e45e9460b60438e159824eaf9cf844d7c5604a9de832e6a85cea3335d9e6223c31e7b349014 SHA512 09971cc5705c421c4440cd51b9aa37da9f8ce992a882d342c0547fe1771199fa61c4924f6d6cd321776f9dcefafd3e244b9cbfce047c4cdd4502dd0a1a1fdaaa
EBUILD bittornado-0.4.1_p20160925-r2.ebuild 1436 BLAKE2B 7b6926352072848ba683c977771c3a77673161a5c7a40494b5e3d799e0c864faa99af78f84c1cff0f5f8ddc1cdf1a25dfc033ff191e70949a63642f837086905 SHA512 5c0b9da4dcd356f6b93117c88f6c8b46507929867e90ba68df5d32572b3b8df6ed16b175790d11b432f59caf329c37bd1886fd6b3d8aced900fb6b62e0d8abe4
+EBUILD bittornado-0.4.1_p20160925-r3.ebuild 1504 BLAKE2B 1037be8fa9f44fbb27682940f1a7c1d0a92be628d2c1ab1979a08b7aa5246d1baf1b6815e5ee4a7eee36c5452fa16786a80173a7486bbf5166813ed0873fbea1 SHA512 90814e5ffdeab6671301ffe231556eadd2983c5c91fc255a5822eda87b4b06129ce5d9cd3ab386d9b6b9bfb3e308fb624bb9471ad3cd0398ef81f14206b435b6
MISC metadata.xml 251 BLAKE2B 2e57f7e8625022d92e5ff0f4ea468077072bf9de6a293b4b3626fc3f6bfa2c34cc1a4a07a2db9c1a5255fb524144a5d8c232e29a331169fee5303274ff5c59fd SHA512 92e2c6c337d3a54187195c333ae1fc7f7dddccad31a4a077037949d81ef125bc2b776cc65db09f1de5cef8bc47faae8dad17696db1ab85c9d81fb02a8cc17f2d
diff --git a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild
new file mode 100644
index 000000000000..36ff74e707da
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN=BitTornado
+MY_P=${MY_PN}-${PV}
+EGIT_COMMIT="ed327c4e1ebbe1fe949be81723527cfda87aeb8d"
+
+DESCRIPTION="John Hoffman's fork of the original bittorrent"
+HOMEPAGE="https://github.com/effigies/BitTornado"
+SRC_URI="https://github.com/effigies/BitTornado/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+# GPL-2 is just for the init script from FILESDIR.
+LICENSE="MIT GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+# Block dev-python/pytest-testmon for bug #693508.
+DEPEND="
+ test? (
+ !!dev-python/pytest-testmon
+ )
+"
+
+S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # https://github.com/effigies/BitTornado/pull/53
+ sed -e 's:"BitTornado.Tracker":\0, "BitTornado.Types":' -i setup.py || die
+ find "${S}" -name '*.py' -print0 | \
+ xargs --null -- \
+ sed -r -i 's:time.clock():time.perf_counter():g ; s:collections.(MutableSet|Set|Sequence|Mapping):collections.abc.\1:g' || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest BitTornado/tests
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newconfd "${FILESDIR}"/bttrack.conf bttrack
+ newinitd "${FILESDIR}"/bttrack.rc bttrack
+}