summaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-p2p/bitcoin-cli
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-p2p/bitcoin-cli')
-rw-r--r--net-p2p/bitcoin-cli/Manifest3
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-0.17.1.ebuild96
2 files changed, 99 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/Manifest b/net-p2p/bitcoin-cli/Manifest
index 89f5624e80b4..6de25fbabc95 100644
--- a/net-p2p/bitcoin-cli/Manifest
+++ b/net-p2p/bitcoin-cli/Manifest
@@ -1,4 +1,7 @@
DIST bitcoin-0.16.3.knots20180918.patches.tar.xz 466344 BLAKE2B c45b96513e4b6317e6a2a55cc3b47302fbe56fb87717ae0197010694013331b5d071b85a11a73c76f08f39e9f0294d3475e89ee63272047df83893de4dbaa390 SHA512 2c3540acc668aeef4b8f01774219736d95395201ddeaccaf70e0bad4a89f05cdd5ffaf630bae0577656efb3580fae92ce0ee4bb1a720ea757ca59e3fd66e1893
+DIST bitcoin-0.17.1.knots20181229.patches.tar.xz 475988 BLAKE2B ce19ccbbeaac48f24b2833858a186494f84cb54ac380c42104f4d16b0a6acb44bc7a83c1b11311e2c566326d7067530ea5f34404def5f22b4825e2fa15aca22d SHA512 da89f9510ee523c712aa137512dda752ab8d115eb8a45a999aa742555621f557694db34162a1f6979922268a3e22563883ea6d9d9a47e5c7613235c0ff06fda0
DIST bitcoin-v0.16.3.tar.gz 6658712 BLAKE2B 2c20b32ea30aed264115d1bd336b62fa28de69cbf116385508718efd7ff22537c3bd402c0965e0f6ddd8e79fc8b51f388f52f885847d36207a24523e927ca63e SHA512 2da25f56fe9b1f5a81815c14e70ff1a69ec15f742424e2c24d71303a71d57c8050dea5d5ba57425bbe0a01a3995ad9b30f0beea5dbafd1632a627cd3fd9a984d
+DIST bitcoin-v0.17.1.tar.gz 6224852 BLAKE2B efc86768ee2d23db83496ff9e62bc86d10c4d24a7343f4c706a4d336aeb94087b2d496db53e393beb5a9dc228bb9fe957ca89254c2fdaf9980b03029efbac2f8 SHA512 ef911ac6b49075a4f3d8db7f9f4dc59590d49847006fa36d7b8cce1634945d418accd95b12da505df38314fb7768f544863169d4b26b230e88dd627a83947466
EBUILD bitcoin-cli-0.16.3.ebuild 2401 BLAKE2B 1f372febaea711cab1ba45ae3b9e29a55138d34b01235f3c6e375b67621b98086bf5b1982c305c50e050164238723e7e4550f686e86fcd80e35d734109d81b8c SHA512 e836b2ff0c3127febca2574bc09bc7e7e98171eafed08af54a8f5f19c9c87410acdb0be2341b8142f76d90ed450bf3ced1bfe57ecf106a77c865c2e72ce018d0
+EBUILD bitcoin-cli-0.17.1.ebuild 2388 BLAKE2B 81e9cb0972e053c324fc0206bd2630cf5438c1b3a7dbbf86b26ee9f2c3baaa4fb57139ae120b8e55d40ae46079fb1dbab2a95be1c118121c2403b5fafb7bcb67 SHA512 7c676fdd6abf87bd7f4e30fad4bf275b107352c4df2b2f421da746c4c75e8f724d09025fc9b0a6c5e2835b9880ae57b21582a149ab901cf541a648a859e5fc06
MISC metadata.xml 620 BLAKE2B e779b6a929a58fad28773a0aba3ef3112df14ce82ce62376b88cbc3519a857faaac6b580d2b5d866b0ec809062cf170e3c29324b03acc005246aea3cef9a0381 SHA512 c253ed29dff90ef2b9cd19b191ad870bd22cbdd371b2f353e724ba950735350225fe6d83c4ca8823ebb395dde9fb5004e781ff78987e2a30c0281ad5e0a4623a
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-0.17.1.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-0.17.1.ebuild
new file mode 100644
index 000000000000..e7296976041c
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-0.17.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+BITCOINCORE_COMMITHASH="ef70f9b52b851c7997a9f1a0834714e3eebc1fd8"
+KNOTS_PV="${PV}.knots20181229"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="Command-line JSON-RPC client specifically for interfacing with bitcoind"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.17.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="knots libressl"
+
+DEPEND="
+ >=dev-libs/boost-1.52.0:=[threads(+)]
+ dev-libs/libevent:=
+ >=dev-libs/univalue-1.0.4:=
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/release-notes.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.17.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2018/12/25/release-${PV}/"
+ fi
+}
+
+src_prepare() {
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ fi
+
+ eapply_user
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ --disable-asm
+ --without-qtdbus
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --enable-util-cli
+ --disable-util-tx
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --without-gui
+ --disable-ccache
+ --disable-static
+ --with-system-univalue
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ newbashcomp contrib/bitcoin-cli.bash-completion ${PN}
+}