summaryrefslogtreecommitdiff
path: root/net-p2p/arti/arti-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 20:16:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 20:16:04 +0000
commitd4725f7e03f4d243d29d408f4b9de39459e00d4c (patch)
tree5b5a3f8042f807f8277163cdc362e03f3333fec7 /net-p2p/arti/arti-9999.ebuild
parent80c51284f0017d5765c7ae39207be9c58f4bfa17 (diff)
gentoo auto-resync : 19:02:2023 - 20:16:03
Diffstat (limited to 'net-p2p/arti/arti-9999.ebuild')
-rw-r--r--net-p2p/arti/arti-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-p2p/arti/arti-9999.ebuild b/net-p2p/arti/arti-9999.ebuild
index 8a8e33f3433e..a4531b132f02 100644
--- a/net-p2p/arti/arti-9999.ebuild
+++ b/net-p2p/arti/arti-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,7 +16,7 @@ if [[ "${PV}" == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.torproject.org/tpo/core/arti"
else
- SRC_URI="https://gitlab.torproject.org/tpo/core/${PN}/-/archive/${PN}-v${PV}/${PN}-${PN}-v${PV}.tar.gz -> ${P}.tar.gz
+ SRC_URI="https://gitlab.torproject.org/tpo/core/${PN}/-/archive/${PN}-v${PV}/${PN}-${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2
$(cargo_crate_uris ${CRATES})"
KEYWORDS="~amd64"
S="${WORKDIR}/${MY_P}"
@@ -42,8 +42,11 @@ src_unpack() {
}
src_compile() {
- pushd crates/arti || die
- cargo_src_compile
+ for crate in crates/*; do
+ pushd crates/arti || die
+ cargo_src_compile
+ popd >/dev/null || die
+ done
}
src_test() {