summaryrefslogtreecommitdiff
path: root/net-nntp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /net-nntp
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/Manifest.gzbin1370 -> 1373 bytes
-rw-r--r--net-nntp/tin/Manifest3
-rw-r--r--net-nntp/tin/files/tin-2.6.1-configure-clang16.patch108
-rw-r--r--net-nntp/tin/tin-2.6.1-r1.ebuild (renamed from net-nntp/tin/tin-2.6.1.ebuild)14
4 files changed, 118 insertions, 7 deletions
diff --git a/net-nntp/Manifest.gz b/net-nntp/Manifest.gz
index 633872535403..739176862ea7 100644
--- a/net-nntp/Manifest.gz
+++ b/net-nntp/Manifest.gz
Binary files differ
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index 1648cbcf859c..87a283f4575e 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1,3 +1,4 @@
+AUX tin-2.6.1-configure-clang16.patch 2473 BLAKE2B af55c171def1e2756bdb305069aeb81b79198397afb38738c4298a1268dc813f7a9c11b941da503d11d5b2d4bac48cb5fa987486dc42a833b1d8241e05779542 SHA512 56ff3b3e71f79145feeaa6e6ce20bf2ebdc3f4b02681423dcabf27ccaa69ffeecb85430b2aed6c07bb9c90fffcaba35801dd44f4e8a81d0fd6fd698cea010af1
DIST tin-2.6.1.tar.xz 1570500 BLAKE2B ec9c54b8b89ecd33a42ede37c8db50828de2dce56ddff01900121903a18d73bde8a06733ca2dfb72c676eb373b5ea874cecb9a1ee7890ada4ad6539d9ff1a435 SHA512 dc9ace5e24cac1efcaac25df1747dd435573130cff4e9c846c89e8faaed8e8120d66a2021332c01f350744155bcb7be608657285560a1a2457b4635cc8fa22b3
-EBUILD tin-2.6.1.ebuild 1970 BLAKE2B b1e42d73336f0d390b9cdab824fc7ff57d6c65487b40bed165eed788725751f0462f1002f6d354f1b3958ae5706960782c387bbec35a799a7b57c987b5d67a8f SHA512 a8edc47a1844bd9e8be30b61f872e07c461a4893f220ba7f6f3f90cc97b85bac2fd8f9eba9dc24a97d52e55964c382e1c6dd29830c3962b898d2880d061e0cbb
+EBUILD tin-2.6.1-r1.ebuild 2025 BLAKE2B 11841532f22a5b6c56c0e5261d24c501ec46f76edc062155d2385e63cc2052e369bae4c3d697e4c0811a63d84b693a112b5ce038e40520398a741c388421a388 SHA512 5cf5e4b1249df5eed6f124499aa3cb56623a5ec2b00e971fff58f4c44fcf91c737718618c56df5eef5923cf552c3fc8f5330af21792698aa526be9f1a2623fde
MISC metadata.xml 408 BLAKE2B a89a2128685a8dc089ba37438352ae8c7171b74c90a8f838a5b7d930b142a90e6d69672ec4ec3f4e97e71c6b38ef9daf988bd5b46d6ccc9f3e4aa0f173075679 SHA512 26855098ca6c2da9fa4edf5620be29402f3c854280e3ca1b26a43af9d630ca34d229a34cc7b513c20c0a03c9e500830fc586f0086668042cff645d08741306b3
diff --git a/net-nntp/tin/files/tin-2.6.1-configure-clang16.patch b/net-nntp/tin/files/tin-2.6.1-configure-clang16.patch
new file mode 100644
index 000000000000..30fb937a6247
--- /dev/null
+++ b/net-nntp/tin/files/tin-2.6.1-configure-clang16.patch
@@ -0,0 +1,108 @@
+https://src.fedoraproject.org/rpms/tin/blob/bbfb5a569a97cde8d4ca95f44979070ad2f57bd0/f/tin-configure-c99.patch
+
+Add missing #include directives to pick up additional prototypes.
+Improves C99 compatibility.
+
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -2165,8 +2165,17 @@ AC_MSG_CHECKING([if application can dump core])
+ AC_CACHE_VAL(cf_cv_corefile,[
+ AC_TRY_RUN([
+ #include <signal.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int found()
+ {
+ struct stat sb;
+@@ -3319,6 +3328,9 @@ AC_DEFUN([CF_FUNC_FORK],
+ [AC_MSG_CHECKING([for fork])
+ AC_CACHE_VAL(cf_cv_func_fork,[
+ AC_TRY_RUN([
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int main()
+ {
+ if (fork() < 0)
+@@ -3465,6 +3477,9 @@ AC_MSG_CHECKING(if the system function returns usable child-status)
+ AC_CACHE_VAL(cf_cv_system_status,[
+ AC_TRY_RUN([
+ #include <stdio.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <signal.h>
+ #if HAVE_SYS_WAIT_H
+ #include <sys/wait.h>
+@@ -3495,7 +3510,11 @@ int main()
+ ],
+ [cf_cv_system_status=no],
+ [AC_TRY_RUN(
+- [int main() { ${cf_cv_main_return:-return}(system("exit 23") != (23 << 8)); }],
++ [
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
++int main() { ${cf_cv_main_return:-return}(system("exit 23") != (23 << 8)); }],
+ [cf_cv_system_status=yes],
+ [cf_cv_system_status=unknown],
+ [cf_cv_system_status=unknown])],
+--- a/configure
++++ b/configure
+@@ -26361,6 +26361,9 @@ else
+ #line 26361 "configure"
+ #include "confdefs.h"
+
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int main()
+ {
+ if (fork() < 0)
+@@ -27366,6 +27369,9 @@ else
+ #include "confdefs.h"
+
+ #include <stdio.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <signal.h>
+ #if HAVE_SYS_WAIT_H
+ #include <sys/wait.h>
+@@ -27417,6 +27423,9 @@ else
+ cat >"conftest.$ac_ext" <<_ACEOF
+ #line 27418 "configure"
+ #include "confdefs.h"
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ int main() { ${cf_cv_main_return:-return}(system("exit 23") != (23 << 8)); }
+ _ACEOF
+ rm -f "conftest$ac_exeext"
+@@ -27764,8 +27773,17 @@ else
+ #include "confdefs.h"
+
+ #include <signal.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int found()
+ {
+ struct stat sb;
diff --git a/net-nntp/tin/tin-2.6.1.ebuild b/net-nntp/tin/tin-2.6.1-r1.ebuild
index 9a5e6df36f8c..cc1eac16cc3e 100644
--- a/net-nntp/tin/tin-2.6.1.ebuild
+++ b/net-nntp/tin/tin-2.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,10 +36,14 @@ DOCS=(
doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,filtering}
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-configure-clang16.patch
+)
+
src_configure() {
tc-export AR CC RANLIB
- econf_args=(
+ local myeconfargs=(
$(use_enable cancel-locks) $(use_with cancel-locks canlock)
$(use_enable debug)
$(use_enable gpg pgp-gpg)
@@ -52,10 +56,8 @@ src_configure() {
--with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.io}}"
--with-pcre=/usr
--with-screen=ncursesw
- )
- # set default paths for utilities
- econf_args+=(
+ # set default paths for utilities
--with-editor="${EPREFIX}"/usr/libexec/editor
--with-gpg="${EPREFIX}"/usr/bin/gpg
--with-ispell="${EPREFIX}"/usr/bin/aspell
@@ -64,7 +66,7 @@ src_configure() {
--with-sum="${EPREFIX}"/usr/bin/sum
)
- econf "${econf_args[@]}"
+ econf "${myeconfargs[@]}"
}
src_compile() {