summaryrefslogtreecommitdiff
path: root/net-news/newsboat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-news/newsboat/files
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-news/newsboat/files')
-rw-r--r--net-news/newsboat/files/newsboat-2.19-json-c-0.14.0.patch34
-rw-r--r--net-news/newsboat/files/newsboat-2.19-libressl.patch82
2 files changed, 116 insertions, 0 deletions
diff --git a/net-news/newsboat/files/newsboat-2.19-json-c-0.14.0.patch b/net-news/newsboat/files/newsboat-2.19-json-c-0.14.0.patch
new file mode 100644
index 000000000000..79c4da5e726a
--- /dev/null
+++ b/net-news/newsboat/files/newsboat-2.19-json-c-0.14.0.patch
@@ -0,0 +1,34 @@
+From db70049f436a965767e8a1273389e1be92e946fa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
+Date: Mon, 13 Apr 2020 12:52:46 +0200
+Subject: [PATCH] Add support for upcoming json-c 0.14.0.
+
+TRUE/FALSE are not defined anymore. 1 and 0 are used instead.
+---
+ src/newsblurapi.cpp | 13 +++++++++++++
+ 1 file changed, 13 insertions(+)
+
+diff --git a/src/newsblurapi.cpp b/src/newsblurapi.cpp
+index 2d1acdae..e124852d 100644
+--- a/src/newsblurapi.cpp
++++ b/src/newsblurapi.cpp
+@@ -9,6 +9,19 @@
+ #include "strprintf.h"
+ #include "utils.h"
+
++/* json-c 0.13.99 does not define TRUE/FALSE anymore
++ * the json-c maintainers replaced them with pure 1/0
++ * https://github.com/json-c/json-c/commit/0992aac61f8b
++ */
++#if defined JSON_C_VERSION_NUM && JSON_C_VERSION_NUM >= ((13 << 8) | 99)
++#ifndef FALSE
++#define FALSE 0
++#endif
++#ifndef TRUE
++#define TRUE 1
++#endif
++#endif
++
+ #define NEWSBLUR_ITEMS_PER_PAGE 6
+
+ namespace newsboat {
diff --git a/net-news/newsboat/files/newsboat-2.19-libressl.patch b/net-news/newsboat/files/newsboat-2.19-libressl.patch
new file mode 100644
index 000000000000..86dff345a56a
--- /dev/null
+++ b/net-news/newsboat/files/newsboat-2.19-libressl.patch
@@ -0,0 +1,82 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index ca8ce060..b738b0b2 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -124,12 +124,12 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
+
+ [[package]]
+ name = "curl-sys"
+-version = "0.4.5"
++version = "0.4.12"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+ "cc 1.0.29 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.66 (registry+https://github.com/rust-lang/crates.io-index)",
+- "libz-sys 1.0.17 (registry+https://github.com/rust-lang/crates.io-index)",
++ "libz-sys 1.0.18 (registry+https://github.com/rust-lang/crates.io-index)",
+ "openssl-sys 0.9.53 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pkg-config 0.3.14 (registry+https://github.com/rust-lang/crates.io-index)",
+ "vcpkg 0.2.6 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -234,12 +234,12 @@ dependencies = [
+ "backtrace 0.3.13 (registry+https://github.com/rust-lang/crates.io-index)",
+ "chrono 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "clap 2.33.0 (registry+https://github.com/rust-lang/crates.io-index)",
+- "curl-sys 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)",
++ "curl-sys 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)",
+ "dirs 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
+ "gettext-rs 0.4.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "gettext-sys 0.19.8 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.66 (registry+https://github.com/rust-lang/crates.io-index)",
+- "libz-sys 1.0.17 (registry+https://github.com/rust-lang/crates.io-index)",
++ "libz-sys 1.0.18 (registry+https://github.com/rust-lang/crates.io-index)",
+ "natord 1.0.9 (registry+https://github.com/rust-lang/crates.io-index)",
+ "nom 4.2.3 (registry+https://github.com/rust-lang/crates.io-index)",
+ "once_cell 0.1.8 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -265,7 +265,7 @@ dependencies = [
+
+ [[package]]
+ name = "libz-sys"
+-version = "1.0.17"
++version = "1.0.18"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+ "cc 1.0.29 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -863,7 +863,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
+ "checksum clap 2.33.0 (registry+https://github.com/rust-lang/crates.io-index)" = "5067f5bb2d80ef5d68b4c87db81601f0b75bca627bc2ef76b141d7b846a3c6d9"
+ "checksum cloudabi 0.0.3 (registry+https://github.com/rust-lang/crates.io-index)" = "ddfc5b9aa5d4507acaf872de71051dfd0e309860e88966e1051e462a077aac4f"
+ "checksum constant_time_eq 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)" = "8ff012e225ce166d4422e0e78419d901719760f62ae2b7969ca6b564d1b54a9e"
+-"checksum curl-sys 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)" = "71c63a540a9ee4e15e56c3ed9b11a2f121239b9f6d7b7fe30f616e048148df9a"
++"checksum curl-sys 0.4.12 (registry+https://github.com/rust-lang/crates.io-index)" = "78800a6de442f65dab6ce26c6f369c14fc585686432bf4b77119d2d384216c31"
+ "checksum dirs 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)" = "88972de891f6118092b643d85a0b28e0678e0f948d7f879aa32f2d5aafe97d2a"
+ "checksum failure 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)" = "795bd83d3abeb9220f257e597aa0080a508b27533824adf336529648f6abf7e2"
+ "checksum failure_derive 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)" = "ea1063915fd7ef4309e222a5a07cf9c319fb9c7836b1f89b85458672dbb127e1"
+@@ -876,7 +876,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
+ "checksum lazy_static 0.2.11 (registry+https://github.com/rust-lang/crates.io-index)" = "76f033c7ad61445c5b347c7382dd1237847eb1bce590fe50365dcb33d546be73"
+ "checksum lazy_static 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)" = "a374c89b9db55895453a74c1e38861d9deec0b01b405a82516e9d5de4820dea1"
+ "checksum libc 0.2.66 (registry+https://github.com/rust-lang/crates.io-index)" = "d515b1f41455adea1313a4a2ac8a8a477634fbae63cc6100e3aebb207ce61558"
+-"checksum libz-sys 1.0.17 (registry+https://github.com/rust-lang/crates.io-index)" = "44ebbc760fd2d2f4d93de09a0e13d97e057612052e871da9985cedcb451e6bd5"
++"checksum libz-sys 1.0.18 (registry+https://github.com/rust-lang/crates.io-index)" = "87f737ad6cc6fd6eefe3d9dc5412f1573865bded441300904d2f42269e140f16"
+ "checksum locale_config 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "14fbee0e39bc2dd6a2427c4fdea66e9826cc1fd09b0a0b7550359f5f6efe1dab"
+ "checksum lock_api 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)" = "62ebf1391f6acad60e5c8b43706dde4582df75c06698ab44511d15016bc2442c"
+ "checksum matches 0.1.8 (registry+https://github.com/rust-lang/crates.io-index)" = "7ffc5c5338469d4d3ea17d269fa8ea3512ad247247c30bd2df69e68309ed0a08"
+diff --git a/rust/libnewsboat/Cargo.toml b/rust/libnewsboat/Cargo.toml
+index 6b9d78dd..5943d43a 100644
+--- a/rust/libnewsboat/Cargo.toml
++++ b/rust/libnewsboat/Cargo.toml
+@@ -16,14 +16,14 @@ xdg = "2.2.0"
+ backtrace = "= 0.3"
+ unicode-width = "0.1.5"
+ nom = "^4.1"
+-curl-sys = "0.4.5"
++curl-sys = "0.4.12"
+ libc = "0.2"
+ gettext-rs = "0.4.1"
+ natord = "1.0.9"
+
+ # We don't use the following crates, but we pin their versions to make sure
+ # that Newsboat builds with Rust 1.25 and later.
+-libz-sys = "= 1.0.17"
++libz-sys = "= 1.0.18"
+
+ # The following constraints close security holes
+ # https://rustsec.org/advisories/RUSTSEC-2019-0009