summaryrefslogtreecommitdiff
path: root/net-news/canto-curses/canto-curses-0.9.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-news/canto-curses/canto-curses-0.9.9.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-news/canto-curses/canto-curses-0.9.9.ebuild')
-rw-r--r--net-news/canto-curses/canto-curses-0.9.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-news/canto-curses/canto-curses-0.9.9.ebuild b/net-news/canto-curses/canto-curses-0.9.9.ebuild
new file mode 100644
index 000000000000..aebb0706e41e
--- /dev/null
+++ b/net-news/canto-curses/canto-curses-0.9.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses(+),threads(+)"
+inherit distutils-r1 multilib
+
+DESCRIPTION="The ncurses client for canto-daemon"
+HOMEPAGE="https://codezen.org/canto-ng/"
+SRC_URI="https://github.com/themoken/canto-curses/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=net-news/canto-daemon-0.9.1[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Respect libdir during plugins installation
+ sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+
+ distutils-r1_python_prepare_all
+}