summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
commit268f9f01921ccb921b794d43092c5f29c1e96c56 (patch)
tree07329b3a8cb5d315182a2ec2b2f4a4b36374724d /net-misc
parente3a48e635527f3e2d2254e9631f7a5758df9c3fb (diff)
gentoo auto-resync : 08:01:2023 - 06:15:27
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin54398 -> 54398 bytes
-rw-r--r--net-misc/curl/Manifest1
-rw-r--r--net-misc/curl/curl-7.87.0-r1.ebuild301
-rw-r--r--net-misc/eventd/Manifest2
-rw-r--r--net-misc/eventd/eventd-0.29.0.ebuild110
5 files changed, 414 insertions, 0 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 7a4cec0ea34c..de09b7fd2ea4 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
index a5a31cf07da6..ff008218b989 100644
--- a/net-misc/curl/Manifest
+++ b/net-misc/curl/Manifest
@@ -9,5 +9,6 @@ DIST curl-7.86.0.tar.xz.asc 488 BLAKE2B a9abe2f3af801b3a48be7db09cb82b6bb83bd26a
DIST curl-7.87.0.tar.xz 2547932 BLAKE2B b272ec928c5ef1728434630d8910f58834327a30570913df9d47921a2810d002bd88b81371005197db857d3a53386420c1e28b1e463e6241d46c1e50fbce0c13 SHA512 aa125991592667280dce3788aabe81487cf8c55b0afc59d675cc30b76055bb7114f5380b4a0e3b6461a8f81bf9812fa26d493a85f7e01d84263d484a0d699ee7
DIST curl-7.87.0.tar.xz.asc 488 BLAKE2B 031d8236b357bd3c519548b181254dc0aea1efc1375738bce04f4f331d35bafe99d1ca394ecf5943ede7cae040854b6d2b478fd305147eb7330f8d50e5d95c96 SHA512 0bcc12bafc4ae50d80128af2cf4bf1a1ec6018ebb8d5b9c49f52b51c0c25acc77e820858965656549ef43c1f923f4e5fe75b0a3523623154b4cfb9dc8a1d76e4
EBUILD curl-7.86.0-r3.ebuild 8760 BLAKE2B 60e6eedd747a7ad46bcc5de3a5e2abedbdb91539863fd7f518afd34383ce3912da321ff5de5df94395a9a94b078902382d9d920df79f0a3f7e8d0265bb1cab44 SHA512 800c3aa95abd8b47322b1055d888726e05ed895537153b0beff1977cf8ab2798f209d463efaadad2ae40e1e8e7e8c45cb1a8e10dc0861b4808d44910b4c85cbf
+EBUILD curl-7.87.0-r1.ebuild 8616 BLAKE2B 918542f2da270535dd8c17181566615646ea2e565f91e5d7a63afd83c4003c9e47c9f78161de0ef0b501796b843f37d0a6763ec89e8a080ebd60cca4fbc1e50c SHA512 03424c105a47683c6c365eb7495fc5d30284308a762001298e736529a3afd213a335c007b09c88311ddaeb6c08a8994e31944ae5fee6855c454a80dca6479fcd
EBUILD curl-7.87.0.ebuild 8615 BLAKE2B cc4c0e7aee79704b5c5723065b2b6f32d8ab9a5eafdad931530ea922fbb21287a916439a65757a8ed62f23ea917c0ead697b9730f8a94dadbe531d287d675b2d SHA512 9623d874ccde6ba6428b2c5a75b0b9bf7589fe428b3fc1891bec799593a655c6c25e70392cda57b78a125cb138571b72206cb9fb6d9954157748b74c088086a2
MISC metadata.xml 2158 BLAKE2B 2b99163e490c531d73aa8c62d428ff4e994537b140e159548d74d52a7c46a2b5e04c992a541298253464f7eaab447d7a680140aadc6b33ecd7d69c35b6aaf6c5 SHA512 a3313197aeedaa7f347e3b6b791d8e5e3bda4292225afcc457ec21cd883347c4cdccaeaa79a7c212e061fdb339be3706815d425d09d8511a4d984f9318164797
diff --git a/net-misc/curl/curl-7.87.0-r1.ebuild b/net-misc/curl/curl-7.87.0-r1.ebuild
new file mode 100644
index 000000000000..1277249868f2
--- /dev/null
+++ b/net-misc/curl/curl-7.87.0-r1.ebuild
@@ -0,0 +1,301 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools prefix multilib-minimal verify-sig
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="https://curl.se/"
+SRC_URI="https://curl.se/download/${P}.tar.xz
+ verify-sig? ( https://curl.se/download/${P}.tar.xz.asc )"
+
+LICENSE="curl"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp rustls samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
+IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_rustls"
+IUSE+=" nghttp3 quiche"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
+
+# Only one default ssl provider can be enabled
+REQUIRED_USE="
+ ssl? (
+ ^^ (
+ curl_ssl_gnutls
+ curl_ssl_mbedtls
+ curl_ssl_nss
+ curl_ssl_openssl
+ curl_ssl_rustls
+ )
+ )"
+
+# lead to lots of false negatives, bug #285669
+RESTRICT="!test? ( test )"
+
+RDEPEND="ldap? ( net-nds/openldap:=[${MULTILIB_USEDEP}] )
+ brotli? ( app-arch/brotli:=[${MULTILIB_USEDEP}] )
+ ssl? (
+ gnutls? (
+ net-libs/gnutls:=[static-libs?,${MULTILIB_USEDEP}]
+ dev-libs/nettle:=[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ mbedtls? (
+ net-libs/mbedtls:=[${MULTILIB_USEDEP}]
+ app-misc/ca-certificates
+ )
+ openssl? (
+ dev-libs/openssl:=[sslv3(-)=,static-libs?,${MULTILIB_USEDEP}]
+ )
+ nss? (
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ dev-libs/nss-pem
+ app-misc/ca-certificates
+ )
+ rustls? (
+ net-libs/rustls-ffi:=[${MULTILIB_USEDEP}]
+ )
+ )
+ http2? ( net-libs/nghttp2:=[${MULTILIB_USEDEP}] )
+ nghttp3? (
+ net-libs/nghttp3[${MULTILIB_USEDEP}]
+ net-libs/ngtcp2[ssl,${MULTILIB_USEDEP}]
+ )
+ quiche? ( >=net-libs/quiche-0.3.0[${MULTILIB_USEDEP}] )
+ idn? ( net-dns/libidn2:=[static-libs?,${MULTILIB_USEDEP}] )
+ adns? ( net-dns/c-ares:=[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ rtmp? ( media-video/rtmpdump[${MULTILIB_USEDEP}] )
+ ssh? ( net-libs/libssh2[${MULTILIB_USEDEP}] )
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )"
+
+# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303
+# rtmp? (
+# media-video/rtmpdump
+# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] )
+# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] )
+# )
+
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ virtual/pkgconfig
+ test? (
+ sys-apps/diffutils
+ )
+ verify-sig? ( sec-keys/openpgp-keys-danielstenberg )"
+
+DOCS=( CHANGES README docs/{FEATURES.md,INTERNALS.md,FAQ,BUGS.md,CONTRIBUTE.md} )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/curl/curlbuild.h
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/curl-config
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.30.0-prefix.patch
+ "${FILESDIR}"/${PN}-respect-cflags-3.patch
+
+ "${FILESDIR}"/${P}-gnutls-openssl-build.patch
+)
+
+src_prepare() {
+ default
+
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # We make use of the fact that later flags override earlier ones
+ # So start with all ssl providers off until proven otherwise
+ # TODO: in the future, we may want to add wolfssl (https://www.wolfssl.com/)
+ local myconf=()
+
+ myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ #myconf+=( --without-default-ssl-backend )
+ if use ssl ; then
+ myconf+=( --without-gnutls --without-mbedtls --without-nss --without-rustls )
+
+ if use gnutls || use curl_ssl_gnutls; then
+ einfo "SSL provided by gnutls"
+ myconf+=( --with-gnutls )
+ fi
+ if use mbedtls || use curl_ssl_mbedtls; then
+ einfo "SSL provided by mbedtls"
+ myconf+=( --with-mbedtls )
+ fi
+ if use nss || use curl_ssl_nss; then
+ einfo "SSL provided by nss"
+ myconf+=( --with-nss --with-nss-deprecated )
+ fi
+ if use openssl || use curl_ssl_openssl; then
+ einfo "SSL provided by openssl"
+ myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
+ fi
+ if use rustls || use curl_ssl_rustls; then
+ einfo "SSL provided by rustls"
+ myconf+=( --with-rustls )
+ fi
+
+ if use curl_ssl_gnutls; then
+ einfo "Default SSL provided by gnutls"
+ myconf+=( --with-default-ssl-backend=gnutls )
+ elif use curl_ssl_mbedtls; then
+ einfo "Default SSL provided by mbedtls"
+ myconf+=( --with-default-ssl-backend=mbedtls )
+ elif use curl_ssl_nss; then
+ einfo "Default SSL provided by nss"
+ myconf+=( --with-default-ssl-backend=nss )
+ elif use curl_ssl_openssl; then
+ einfo "Default SSL provided by openssl"
+ myconf+=( --with-default-ssl-backend=openssl )
+ elif use curl_ssl_rustls; then
+ einfo "Default SSL provided by rustls"
+ myconf+=( --with-default-ssl-backend=rustls )
+ else
+ eerror "We can't be here because of REQUIRED_USE."
+ fi
+
+ else
+ myconf+=( --without-ssl )
+ einfo "SSL disabled"
+ fi
+
+ # These configuration options are organized alphabetically
+ # within each category. This should make it easier if we
+ # ever decide to make any of them contingent on USE flags:
+ # 1) protocols first. To see them all do
+ # 'grep SUPPORT_PROTOCOLS configure.ac'
+ # 2) --enable/disable options second.
+ # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
+ # 3) --with/without options third.
+ # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
+
+ myconf+=(
+ $(use_enable alt-svc)
+ --enable-crypto-auth
+ --enable-dict
+ --disable-ech
+ --enable-file
+ $(use_enable ftp)
+ $(use_enable gopher)
+ $(use_enable hsts)
+ --enable-http
+ $(use_enable imap)
+ $(use_enable ldap)
+ $(use_enable ldap ldaps)
+ --enable-ntlm
+ --disable-ntlm-wb
+ $(use_enable pop3)
+ --enable-rt
+ --enable-rtsp
+ $(use_enable samba smb)
+ $(use_with ssh libssh2)
+ $(use_enable smtp)
+ $(use_enable telnet)
+ $(use_enable tftp)
+ --enable-tls-srp
+ $(use_enable adns ares)
+ --enable-cookies
+ --enable-dateparse
+ --enable-dnsshuffle
+ --enable-doh
+ --enable-symbol-hiding
+ --enable-http-auth
+ $(use_enable ipv6)
+ --enable-largefile
+ --enable-manual
+ --enable-mime
+ --enable-netrc
+ $(use_enable progress-meter)
+ --enable-proxy
+ --disable-sspi
+ $(use_enable static-libs static)
+ --enable-pthreads
+ --enable-threaded-resolver
+ --disable-versioned-symbols
+ --without-amissl
+ --without-bearssl
+ $(use_with brotli)
+ --without-fish-functions-dir
+ $(use_with http2 nghttp2)
+ --without-hyper
+ $(use_with idn libidn2)
+ $(use_with kerberos gssapi "${EPREFIX}"/usr)
+ --without-libgsasl
+ --without-libpsl
+ --without-msh3
+ $(use_with nghttp3)
+ $(use_with nghttp3 ngtcp2)
+ $(use_with quiche)
+ $(use_with rtmp librtmp)
+ --without-schannel
+ --without-secure-transport
+ $(use_enable websockets)
+ --without-winidn
+ --without-wolfssl
+ --with-zlib
+ $(use_with zstd)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! multilib_is_native_abi; then
+ # avoid building the client
+ sed -i -e '/SUBDIRS/s:src::' Makefile || die
+ sed -i -e '/SUBDIRS/s:scripts::' Makefile || die
+ fi
+
+ # Fix up the pkg-config file to be more robust.
+ # https://github.com/curl/curl/issues/864
+ local priv=() libs=()
+ # We always enable zlib.
+ libs+=( "-lz" )
+ priv+=( "zlib" )
+ if use http2; then
+ libs+=( "-lnghttp2" )
+ priv+=( "libnghttp2" )
+ fi
+ if use quiche; then
+ libs+=( "-lquiche" )
+ priv+=( "quiche" )
+ fi
+ if use nghttp3; then
+ libs+=( "-lnghttp3" "-lngtcp2" )
+ priv+=( "libnghttp3" "libngtcp2" )
+ fi
+ if use ssl && use curl_ssl_openssl; then
+ libs+=( "-lssl" "-lcrypto" )
+ priv+=( "openssl" )
+ fi
+ grep -q Requires.private libcurl.pc && die "need to update ebuild"
+ libs=$(printf '|%s' "${libs[@]}")
+ sed -i -r \
+ -e "/^Libs.private/s:(${libs#|})( |$)::g" \
+ libcurl.pc || die
+ echo "Requires.private: ${priv[*]}" >> libcurl.pc || die
+}
+
+multilib_src_test() {
+ # See https://github.com/curl/curl/blob/master/tests/runtests.pl#L5721
+ # -n: no valgrind (unreliable in sandbox and doesn't work correctly on all arches)
+ # -v: verbose
+ # -a: keep going on failure (so we see everything which breaks, not just 1st test)
+ # -k: keep test files after completion
+ # -am: automake style TAP output
+ # -p: print logs if test fails
+ # Note: if needed, we can disable tests. See e.g. Fedora's packaging
+ # or just read https://github.com/curl/curl/tree/master/tests#run.
+ multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+ rm -rf "${ED}"/etc/ || die
+}
diff --git a/net-misc/eventd/Manifest b/net-misc/eventd/Manifest
index fda4838cf58d..b5209c06143b 100644
--- a/net-misc/eventd/Manifest
+++ b/net-misc/eventd/Manifest
@@ -1,4 +1,6 @@
AUX eventd-0.27.0-fno-common.patch 323 BLAKE2B a6ddf695edf40bfb6a1b247d0a82d899d5162f3b59ca3a5879b300deafdbdae31557edea1ccfc4bc183cc1e9d3ea2124305951ad29dfab15428cf9ba0fab4997 SHA512 5ca3560d6b046debd58ea682d302f22a9884426112cecedb577b5f1da5de10489f435f55978affaf6fd69d43d72d547f617e141b209d9e02e32651286afd639d
DIST eventd-0.27.0.tar.xz 188000 BLAKE2B 06779168e9049714aabc051f8a85a5e5764509c3deceddd300c103f4831b6679f082748858bebb9629dcd47fa0b570158c6cf2b665167ab8e20a7dc0f12cc00f SHA512 586fdf36742cfda5a3c5e4cf4600307b8d699701fdf32eec25a7b294c815ded6e7e41210e65c706c34c5f2d911cadec89b677f082dad183f486fb7d1a55a2302
+DIST eventd-0.29.0.tar.xz 196276 BLAKE2B 5d9fd352df65a8bb00e6bf1f7600dadc1bf3d3c98ed02eb3ad3cb6148dc8370dd2bc2ecda7e2b8f60d90b7adebb2187490bb6c934bc0bf8b5d0cd38bb26a8c36 SHA512 32407049df0abba68eb6310a86f8c6ec42774bd55934e5927d92f9eb75fc11f32e790904641a0113d8668c66591a0a82246b3240ba1a9517b243301bb96227b8
EBUILD eventd-0.27.0-r2.ebuild 2662 BLAKE2B 6074a07d9812b093a8c27c14cb4e5f9e57595befe314209049a85e86c822382aa6bccc137c3eadde3189b58d4ac4f3bad4a45192d9598fa9ac8de2f8ef17abea SHA512 e66615b2fdcb7e02fde31ed67583294e78b7d2d2552ea1016e871985a5623ada9228e04b069a2f83f37e6e2905c3aee0f4081efee8919a4a7dc203dd027d6b14
+EBUILD eventd-0.29.0.ebuild 2627 BLAKE2B 2b1188731f35f798ba884ac46031f05fa317ecbd868daa4dc0056f8fdbb2cccfafa87822ca8262927a1ce8bbf9df33691cb9639a54d49892fa6b2a0160d31f1f SHA512 3bd79a4f34bbed80930a88bdcb55e0074b03f5de0297db999e14d5068efda378b2b3f61fc0bb9e00d924d1d841b9190f6da71a6a491f5ff67bba7e04dc96fafa
MISC metadata.xml 908 BLAKE2B 070d6de6db62dbfecb990dde8a928f4bafe44f25c208f1136a600992c90a7978787df0f77f1ed82cdc203430d428fc4371136ab13ee5672090f6cbd6cf13bf40 SHA512 db11d00d0d0d04b2265340fcf4d28d73ed053135a8c7e40b6f1fbb6c22c23a9cf777c0ba40540d38de103c04744cc4354abf0134fdb3c325e8a733179794073d
diff --git a/net-misc/eventd/eventd-0.29.0.ebuild b/net-misc/eventd/eventd-0.29.0.ebuild
new file mode 100644
index 000000000000..b475370e4e82
--- /dev/null
+++ b/net-misc/eventd/eventd-0.29.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson systemd
+
+DESCRIPTION="A small daemon to act on remote or local events"
+HOMEPAGE="https://www.eventd.org/"
+SRC_URI="https://www.eventd.org/download/eventd/${P}.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+ ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
+ pulseaudio purple speech systemd test upnp webhook websocket +X zeroconf"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ X? ( notification )
+ fbcon? ( notification )
+ notification? ( || ( X fbcon ) )
+ test? ( websocket )
+"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ sys-apps/util-linux
+ x11-libs/libxkbcommon
+ introspection? ( dev-libs/gobject-introspection )
+ libcanberra? ( media-libs/libcanberra )
+ libnotify? ( x11-libs/gdk-pixbuf:2 )
+ notification? (
+ gnome-base/librsvg
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ X? (
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb:=[xkb(+)]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ )
+ )
+ pulseaudio? (
+ media-libs/libsndfile
+ media-sound/pulseaudio
+ )
+ purple? ( net-im/pidgin )
+ speech? ( app-accessibility/speech-dispatcher )
+ systemd? ( sys-apps/systemd:= )
+ upnp? ( >=net-libs/gssdp-1.2:0= )
+ webhook? ( net-libs/libsoup:3.0 )
+ websocket? ( net-libs/libsoup:3.0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ fbcon? ( virtual/os-headers )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ net-libs/glib-networking[ssl]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use ipv6; then
+ CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ # wayland disabled due to missing dep in ::gentoo, wayland-wall
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ -Dnd-wayland=false
+ -Dvapi=false
+ $(meson_feature websocket)
+ $(meson_feature zeroconf dns-sd)
+ $(meson_feature upnp ssdp)
+ $(meson_use ipv6)
+ $(meson_use systemd)
+ $(meson_use notification notification-daemon)
+ $(meson_use X nd-xcb)
+ $(meson_use fbcon nd-fbdev)
+ $(meson_use purple im)
+ $(meson_use pulseaudio sound)
+ $(meson_use speech tts)
+ $(meson_use webhook)
+ $(meson_use libnotify)
+ $(meson_use libcanberra)
+ $(meson_use introspection gobject-introspection)
+ $(meson_use debug debug-output)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ EVENTD_TESTS_TMP_DIR="${T}" meson_src_test
+}