summaryrefslogtreecommitdiff
path: root/net-misc/zerotier/zerotier-1.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/zerotier/zerotier-1.2.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/zerotier/zerotier-1.2.4.ebuild')
-rw-r--r--net-misc/zerotier/zerotier-1.2.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/zerotier/zerotier-1.2.4.ebuild b/net-misc/zerotier/zerotier-1.2.4.ebuild
new file mode 100644
index 000000000000..9150c0a91052
--- /dev/null
+++ b/net-misc/zerotier/zerotier-1.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs systemd
+
+HOMEPAGE="https://www.zerotier.com/"
+DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
+SRC_URI="https://github.com/zerotier/ZeroTierOne/archive/${PV}.tar.gz -> zerotier-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/ZeroTierOne-${PV}"
+
+RDEPEND="
+ net-libs/miniupnpc
+ net-libs/libnatpmp
+ dev-libs/json-glib
+ net-libs/http-parser"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.9.3"
+
+QA_PRESTRIPPED="/usr/sbin/zerotier-one"
+
+DOCS=( README.md AUTHORS.md )
+
+src_compile() {
+ append-ldflags -Wl,-z,noexecstack
+ emake CXX="$(tc-getCXX)" one
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.init" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ doman "${S}/doc/zerotier-"{cli.1,idtool.1,one.8}
+}