summaryrefslogtreecommitdiff
path: root/net-misc/zerotier/zerotier-1.2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /net-misc/zerotier/zerotier-1.2.4-r1.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'net-misc/zerotier/zerotier-1.2.4-r1.ebuild')
-rw-r--r--net-misc/zerotier/zerotier-1.2.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/zerotier/zerotier-1.2.4-r1.ebuild b/net-misc/zerotier/zerotier-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..bd328bd24296
--- /dev/null
+++ b/net-misc/zerotier/zerotier-1.2.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs systemd
+
+HOMEPAGE="https://www.zerotier.com/"
+DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
+SRC_URI="https://github.com/zerotier/ZeroTierOne/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/ZeroTierOne-${PV}"
+
+RDEPEND="
+ net-libs/miniupnpc
+ net-libs/libnatpmp
+ dev-libs/json-glib
+ net-libs/http-parser"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.9.3"
+
+QA_PRESTRIPPED="/usr/sbin/zerotier-one"
+
+DOCS=( README.md AUTHORS.md )
+
+src_compile() {
+ append-ldflags -Wl,-z,noexecstack
+ emake CXX="$(tc-getCXX)" one
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.init" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ doman "${S}/doc/zerotier-"{cli.1,idtool.1,one.8}
+}