summaryrefslogtreecommitdiff
path: root/net-misc/ytmdl/ytmdl-2022.12.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 20:08:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 20:08:29 +0000
commit6dfd9c39ab68bbc917ffc374b2fa515f676f891f (patch)
treec9963a9e1e09b0e237a5c00736caa588c5a0a38f /net-misc/ytmdl/ytmdl-2022.12.25.ebuild
parentadb727afeb568404873e8cbc91ba93d3d49eff13 (diff)
gentoo auto-resync : 26:12:2022 - 20:08:29
Diffstat (limited to 'net-misc/ytmdl/ytmdl-2022.12.25.ebuild')
-rw-r--r--net-misc/ytmdl/ytmdl-2022.12.25.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/ytmdl/ytmdl-2022.12.25.ebuild b/net-misc/ytmdl/ytmdl-2022.12.25.ebuild
new file mode 100644
index 000000000000..89fc54c4e776
--- /dev/null
+++ b/net-misc/ytmdl/ytmdl-2022.12.25.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Simple app to get songs from youtube in mp3 format"
+HOMEPAGE="https://ytmdl.deepjyoti30.dev/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=net-misc/yt-dlp-2022.3.8.2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/ffmpeg-python[${PYTHON_USEDEP}]
+ dev-python/itunespy[${PYTHON_USEDEP}]
+ dev-python/pyDes[${PYTHON_USEDEP}]
+ dev-python/python-musicbrainzngs[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/simber[${PYTHON_USEDEP}]
+ dev-python/spotipy[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/youtube-search-python[${PYTHON_USEDEP}]
+ dev-python/ytmusicapi[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ net-misc/downloader-cli[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp ${PN}.bash ${PN}
+}