summaryrefslogtreecommitdiff
path: root/net-misc/ytfzf/ytfzf-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-12 11:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-12 11:48:47 +0100
commit0d64e4aba03bad82adf8ae589fd10b9c219b92aa (patch)
treea0db81898e976e96ec178518d7b636c80d8e26d3 /net-misc/ytfzf/ytfzf-2.6.0.ebuild
parent8d9dd6a2b8f0525f6337deacd0cc20027f645396 (diff)
gentoo auto-resync : 12:05:2023 - 11:48:47
Diffstat (limited to 'net-misc/ytfzf/ytfzf-2.6.0.ebuild')
-rw-r--r--net-misc/ytfzf/ytfzf-2.6.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/ytfzf/ytfzf-2.6.0.ebuild b/net-misc/ytfzf/ytfzf-2.6.0.ebuild
new file mode 100644
index 000000000000..62121ae8df88
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal +thumbnails"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ thumbnails? (
+ || (
+ media-gfx/ueberzugpp
+ media-gfx/ueberzug
+ )
+ )
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}