summaryrefslogtreecommitdiff
path: root/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild')
-rw-r--r--net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
new file mode 100644
index 000000000000..65224da4bf5b
--- /dev/null
+++ b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="X11-based passphrase dialog for use with OpenSSH"
+HOMEPAGE="http://www.liquidmeme.net/software/x11-ssh-askpass
+ https://github.com/sigmavirus24/x11-ssh-askpass"
+SRC_URI="http://www.liquidmeme.net/software/x11-ssh-askpass/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/ssh
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE"
+DEPEND="${RDEPEND}"
+BDEPEND="x11-misc/imake
+ app-text/rman"
+
+src_configure() {
+ econf --libexecdir=/usr/$(get_libdir)/misc \
+ --disable-installing-app-defaults
+ xmkmf || die "xmkmf failed"
+}
+
+src_compile() {
+ emake includes
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ newman x11-ssh-askpass.man x11-ssh-askpass.1
+ dosym ../"$(get_libdir)"/misc/x11-ssh-askpass /usr/bin/x11-ssh-askpass
+}