summaryrefslogtreecommitdiff
path: root/net-misc/wput/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
commit2ad011cd42b40aebf90105be4521fb1727266d1d (patch)
treed9dc4f7c1665a6ba336ba8a9fa773f1292895b76 /net-misc/wput/files
parente0dcb1c4ea48292b379fadd53f55f1df42cf7eab (diff)
gentoo auto-resync : 26:09:2022 - 15:08:08
Diffstat (limited to 'net-misc/wput/files')
-rw-r--r--net-misc/wput/files/wput-0.6.2_p20130413_p11-no-compress-manpages.patch39
-rw-r--r--net-misc/wput/files/wput-0.6.2_p20130413_p11-xopen_source-strdup.patch14
2 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/wput/files/wput-0.6.2_p20130413_p11-no-compress-manpages.patch b/net-misc/wput/files/wput-0.6.2_p20130413_p11-no-compress-manpages.patch
new file mode 100644
index 000000000000..cc0c6e8e1b8b
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6.2_p20130413_p11-no-compress-manpages.patch
@@ -0,0 +1,39 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -10,7 +10,6 @@ bindir=@bindir@
+ all clean:
+ cd po && $(MAKE) $(MAKEDEFS) $@
+ cd src && $(MAKE) $(MAKEDEFS) $@
+- cd doc && $(MAKE) $(MAKEDEFS) $@
+
+ win-clean:
+ cd src && $(MAKE) $(MAKEDEFS) $@
+@@ -20,9 +20,9 @@ install: all
+ install -m0755 -d $(destdir)$(bindir)
+ install -m0755 -d $(destdir)$(mandir)
+ install -m0755 wput $(destdir)$(bindir)
+- install -m0644 doc/wput.1.gz $(destdir)$(mandir)
++ install -m0644 doc/wput.1 $(destdir)$(mandir)
+ cd $(destdir)$(bindir) && ln -s wput wdel
+- install -m0644 doc/wdel.1.gz $(destdir)$(mandir)
++ install -m0644 doc/wdel.1 $(destdir)$(mandir)
+ @echo "----------------"
+ @echo "Wput and Wdel installed. See 'wput/wdel -h' or 'man wput/wdel' for"
+ @echo "usage information."
+@@ -34,6 +34,6 @@ install: all
+ uninstall:
+ rm -f $(destdir)$(bindir)/wput
+ rm -f $(destdir)$(bindir)/wdel
+- rm -f $(destdir)$(mandir)/wput.1.gz
+- rm -f $(destdir)$(mandir)/wdel.1.gz
++ rm -f $(destdir)$(mandir)/wput.1
++ rm -f $(destdir)$(mandir)/wdel.1
+
+--- a/doc/Makefile
++++ /dev/null
+@@ -1,5 +0,0 @@
+-all:
+- gzip < wput.1 > wput.1.gz
+- gzip < wdel.1 > wdel.1.gz
+-clean:
+- rm -f wput.1.gz wdel.1.gz
diff --git a/net-misc/wput/files/wput-0.6.2_p20130413_p11-xopen_source-strdup.patch b/net-misc/wput/files/wput-0.6.2_p20130413_p11-xopen_source-strdup.patch
new file mode 100644
index 000000000000..e2426d3fc25f
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6.2_p20130413_p11-xopen_source-strdup.patch
@@ -0,0 +1,14 @@
+ftp-ls.c:319:22: error: call to undeclared library function 'strdup' with type 'char *(const char *)'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+ cur.linkto = xstrdup (p + 4);
+ ^
+--- a/src/ftp-ls.c
++++ b/src/ftp-ls.c
+@@ -29,7 +29,7 @@ file, but you are not obligated to do so. If you do not wish to do
+ so, delete this exception statement from your version. */
+
+ #include "config.h"
+-#define _XOPEN_SOURCE
++#define _XOPEN_SOURCE 600
+ #include <time.h>
+ #include <stdio.h>
+ #include <stdlib.h>