summaryrefslogtreecommitdiff
path: root/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild')
-rw-r--r--net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild b/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
new file mode 100644
index 000000000000..11ea46fa1db4
--- /dev/null
+++ b/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A command-line tool for taking JPEG snapshots of VNC servers"
+HOMEPAGE="http://vncsnapshot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="
+ virtual/jpeg
+ >=sys-libs/zlib-1.1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-amd64grey.patch"
+ sed \
+ -e 's:-I/usr/local/include::g' \
+ -e 's:-L/usr/local/lib::g' \
+ -e '/^all:/s|$(SUBDIRS:.dir=.all)||g' \
+ -e '/^vnc/s|$| $(SUBDIRS:.dir=.all)|g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ #note: We override CDEBUGFLAGS instead of CFLAGS because otherwise
+ # we lost the INCLUDES in the makefile.
+ # bug #295741
+ emake CDEBUGFLAGS="${CXXFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin vncsnapshot
+ cp vncsnapshot.man1 vncsnapshot.1
+ doman vncsnapshot.1
+}