summaryrefslogtreecommitdiff
path: root/net-misc/vde/vde-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 09:17:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 09:17:35 +0000
commit54c42eb42df420f52e032fcba7727c326ef01094 (patch)
tree0dee719f67aa7ad3bfb64c3a46912acad885d738 /net-misc/vde/vde-9999.ebuild
parenta8b01fd62375e0df65d5f8f20c5ee142ec6739b6 (diff)
gentoo auto-resync : 05:11:2022 - 09:17:35
Diffstat (limited to 'net-misc/vde/vde-9999.ebuild')
-rw-r--r--net-misc/vde/vde-9999.ebuild75
1 files changed, 34 insertions, 41 deletions
diff --git a/net-misc/vde/vde-9999.ebuild b/net-misc/vde/vde-9999.ebuild
index 32de524f78b9..4cacbb0f887b 100644
--- a/net-misc/vde/vde-9999.ebuild
+++ b/net-misc/vde/vde-9999.ebuild
@@ -1,78 +1,71 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit flag-o-matic
+inherit autotools flag-o-matic
if [[ ${PV} == 9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/virtualsqaure/MY_PN"
-elif [[ ${PV} = *_p* ]]; then
- inherit autotools
- MY_PN="vde-2"
- COMMIT="c7b36a57831a9067c8619c3e17a03e595623b3eb"
- SRC_URI="https://github.com/virtualsquare/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-
- S="${WORKDIR}/${MY_PN}-${COMMIT}"
+ EGIT_REPO_URI="https://github.com/virtualsquare/vde-2"
+ inherit git-r3
+elif [[ ${PV} == *_p* ]]; then
+ MY_COMMIT="c7b36a57831a9067c8619c3e17a03e595623b3eb"
+ SRC_URI="https://github.com/virtualsquare/vde-2/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vde-2-${COMMIT}"
else
MY_P="${PN}2-${PV}"
- SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
- S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/virtualsquare/vde-2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vde-2-${PV}"
fi
DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
-HOMEPAGE="https://virtualsquare.org"
+HOMEPAGE="https://virtualsquare.org/"
LICENSE="GPL-2"
SLOT="0"
-# upstream switched to wolfssl
+if [[ ${PV} != 9999 ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
IUSE="pcap selinux static-libs"
-COMMON_DEPS="pcap? ( net-libs/libpcap )"
-DEPEND="${COMMON_DEPS}"
-RDEPEND="${COMMON_DEPS}
+DEPEND="pcap? ( net-libs/libpcap )"
+RDEPEND="
+ ${DEPEND}
acct-group/qemu
- selinux? ( sec-policy/selinux-vde )"
+ selinux? ( sec-policy/selinux-vde )
+"
-# upstream switched to wolfssl
src_prepare() {
default
- if [[ ${PV} == 9999 ]] || [[ ${PV} == *_p* ]]; then
- eautoreconf
- fi
-# upstream switched to wolfssl
-# has_version ">=dev-libs/openssl-1.1.0" && \
-# eapply "${FILESDIR}/${PN}-2.3.2-openssl-1.1.patch"
+
+ eautoreconf
}
src_configure() {
filter-flags -O0 -Os
-# upstream switched to wolfssl
-# $(use_enable ssl cryptcab) \
- econf \
- --disable-python \
- --disable-cryptcab \
- $(use_enable pcap) \
+
+ local myeconfargs=(
+ # Upstream switched to wolfssl, so no SSL support for now
+ --disable-cryptcab
+ $(use_enable pcap)
$(use_enable static-libs static)
-}
+ )
-src_compile() {
- # https://github.com/virtualsquare/vde-2/issues/6
- emake -j1
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -type f -delete || die
+
+ find "${ED}" -name '*.la' -type f -delete || die
newinitd "${FILESDIR}"/vde.init-r1 vde
newconfd "${FILESDIR}"/vde.conf-r1 vde
}
pkg_postinst() {
- einfo "To start vde automatically add it to the default runlevel:"
+ einfo "To start vde automatically, add it to the default runlevel:"
einfo "# rc-update add vde default"
- einfo "You need to setup tap0 in /etc/conf.d/net"
- einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+ einfo "You need to setup tap0 in ${EROOT}/etc/conf.d/net"
+ einfo "To use it as an user, be sure to set a group in ${EROOT}/etc/conf.d/vde"
}