summaryrefslogtreecommitdiff
path: root/net-misc/unison
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
commit4482d99f0743195c71b2b03faa8bfbda5501910b (patch)
tree853f042c5e26ca4bce5b091ccc3128b9a763984a /net-misc/unison
parent9c4ecbcb1ba97e8bfd6dac8c2433fb9fdfee5fe6 (diff)
gentoo auto-resync : 27:01:2024 - 12:56:47
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/Manifest2
-rw-r--r--net-misc/unison/unison-2.53.3.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 2b708d7ba995..476415a8d264 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -1,3 +1,5 @@
DIST unison-2.51.5.tar.gz 1385407 BLAKE2B cdad4683518ec9c7c43d9107d8533fa393a68f602782d96ddba345df07b1ef70cc2ebf7dfd205fc7535349553a5e0d3c2931099bde99e5c736bc815ccdd294f8 SHA512 4a31df4d043d2b7552438f9fc2056098b9a35cd1cae1a037083cb56d91ec6fec0c3164de73914ff46cb8821f78c1594f48bf0334a94d9d706cd82ce3a6b70440
+DIST unison-2.53.3.tar.gz 1415490 BLAKE2B 1142419781f5084da7ae8d043897f2f80aa4c3770a1c5cb44f8d7f669f718c41dd7fa6d13069cd95c71842233309eb886f63ab525e5e446ff761ea970de0e794 SHA512 f3fafd5e1a2950a00ed8bcc682036180ea40eff1ccfa1fc671cca49954890a535ee48faf1e8e62002563143e5479b9df1eca1db1caf03dffc50449fb467b8e2b
EBUILD unison-2.51.5.ebuild 2581 BLAKE2B 390079d02bc2ab9a312f03309ce0c051f6bd6e470f01ccb8462abc47c20e613b5946063d9c884ea198a140ba8ac3fc30beaa450fcec97f127097c22535919820 SHA512 551e0153b1e156557ff22b8f6807b51cccf163210a8454cceafc0746966252c72e8e50627d65d1f6dd8170dfe64559d7dd6225f25242a1be721c2624ec5abf61
+EBUILD unison-2.53.3.ebuild 2229 BLAKE2B 2490f9a9c31179c9c5bd00a657cecb767ccf2039c9eef6ef586740891fc4128948beb7b6be621acddcab8b67b25b3a1e8d2061b4ce72d41c603bdd2aafa67188 SHA512 8f673f62833f15a79af93c438e10d9129694c668e80160e0799c48d86eea940bef4b3ea7af1da28604d88ca3d0e28817c3c0d24404b8196642f71dcb89f95c21
MISC metadata.xml 451 BLAKE2B e84c101fb93728a569747cfd4ba69e4e746bde0ec1154aa940dfb963fe4313f6e37a2725df55d7921139b52ea021d1196592d8323617f084f50c18e4cff7cc32 SHA512 708a52b7f47377099de539ee768951d67e98a8173c6b168547135cfa80fda37c8c26cf9dfee038c76bc5bdabc966652e686f818af35905e58bd17396181c02ea
diff --git a/net-misc/unison/unison-2.53.3.ebuild b/net-misc/unison/unison-2.53.3.ebuild
new file mode 100644
index 000000000000..0de016690ac1
--- /dev/null
+++ b/net-misc/unison/unison-2.53.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://github.com/bcpierce00/unison"
+SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug doc gtk +ocamlopt threads"
+
+BDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ doc? ( app-text/dvipsk
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latex )"
+DEPEND="gtk? ( dev-ml/lablgtk:3=[ocamlopt?] )"
+RDEPEND="gtk? ( dev-ml/lablgtk:3=[ocamlopt?]
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ >=app-eselect/eselect-unison-0.4
+ >=dev-lang/ocaml-4.08"
+
+DOCS=( CONTRIB README ROADMAP.txt TODO.txt )
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf+=( THREADS=true )
+ fi
+
+ if use debug; then
+ myconf+=( DEBUGGING=true )
+ fi
+
+ if use gtk; then
+ myconf+=( UISTYLE=gtk3 )
+ else
+ myconf+=( UISTYLE=text )
+ fi
+
+ use ocamlopt || myconf+=( NATIVE=false )
+
+ if use doc; then
+ VARTEXFONTS="${T}/fonts" emake "${myconf[@]}" CFLAGS="" HEVEA=false docs
+ fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake "${myconf[@]}" CFLAGS="" src
+
+ emake manpage
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+ doman ../man/unison.1
+
+ if use gtk; then
+ newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
+ make_desktop_entry ${PN}-${SLOT} "${PN} (${SLOT})" "${PN}-${SLOT}"
+ fi
+
+ if use doc; then
+ DOCS+=( ../doc/unison-manual.pdf )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update || die
+
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}