summaryrefslogtreecommitdiff
path: root/net-misc/unison/unison-2.51.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
commitbed3b604e16fc6075e29f1af8d47507a07035bd3 (patch)
tree1f5d57fd86e90db37f62afb463f4b4c08a2b6eda /net-misc/unison/unison-2.51.5.ebuild
parentd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (diff)
gentoo auto-resync : 21:06:2024 - 00:11:18
Diffstat (limited to 'net-misc/unison/unison-2.51.5.ebuild')
-rw-r--r--net-misc/unison/unison-2.51.5.ebuild109
1 files changed, 0 insertions, 109 deletions
diff --git a/net-misc/unison/unison-2.51.5.ebuild b/net-misc/unison/unison-2.51.5.ebuild
deleted file mode 100644
index 914cd4876cd3..000000000000
--- a/net-misc/unison/unison-2.51.5.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop xdg-utils
-
-DESCRIPTION="Two-way cross-platform file synchronizer"
-HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/ https://github.com/bcpierce00/unison"
-SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="debug doc gtk +ocamlopt threads"
-
-BDEPEND="dev-lang/ocaml:=[ocamlopt?]
- doc? ( app-text/dvipsk
- app-text/ghostscript-gpl
- dev-texlive/texlive-latex
- dev-tex/hevea
- www-client/lynx
- )"
-DEPEND="gtk? ( dev-ml/lablgtk:2=[ocamlopt?] )"
-RDEPEND="gtk? ( dev-ml/lablgtk:2=[ocamlopt?]
- || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
- >=app-eselect/eselect-unison-0.4"
-
-DOCS=( CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
-
-QA_FLAGS_IGNORED="usr/bin/${PN}-fsmonitor-${SLOT}"
-
-src_prepare() {
- default
- # https://github.com/bcpierce00/unison/issues/416
- sed -e "/ifdef\ HEVEA/,/endif/d" -i doc/Makefile || die
- # https://github.com/bcpierce00/unison/pull/415
- sed -e "/myName/d" -i doc/docs.ml || die
-}
-
-src_compile() {
- local myconf
-
- if use threads; then
- myconf+=( THREADS=true )
- fi
-
- if use debug; then
- myconf+=( DEBUGGING=true )
- fi
-
- if use gtk; then
- myconf+=( UISTYLE=gtk2 )
- else
- myconf+=( UISTYLE=text )
- fi
-
- use ocamlopt || myconf+=( NATIVE=false )
-
- if use doc; then
- VARTEXFONTS="${T}/fonts" emake "${myconf[@]}" CFLAGS="" HEVEA=true docs
- fi
-
- # Discard cflags as it will try to pass them to ocamlc...
- emake "${myconf[@]}" CFLAGS="" src
-}
-
-src_test() {
- emake test CFLAGS=""
-}
-
-src_install() {
- # install manually, since it's just too much
- # work to force the Makefile to do the right thing.
- local binname
- cd src || die
- for binname in unison unison-fsmonitor; do
- newbin ${binname} ${binname}-${SLOT}
- done
-
- if use gtk; then
- newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
- make_desktop_entry ${PN}-${SLOT} "${PN} (${SLOT})" "${PN}-${SLOT}"
- fi
-
- if use doc; then
- DOCS+=( ../doc/unison-manual.pdf )
- HTML_DOCS=( "../doc/unison-manual.html" )
- fi
-
- einstalldocs
-}
-
-pkg_postinst() {
- elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
- elog "in your profile files to access exactly this version over ssh."
- elog "Or you can use 'eselect unison' to set the version."
- eselect unison update || die
-
- if use gtk; then
- xdg_icon_cache_update
- fi
-}
-
-pkg_postrm() {
- if use gtk; then
- xdg_icon_cache_update
- fi
-}