summaryrefslogtreecommitdiff
path: root/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /net-misc/unison/files/unison-2.48.4-Makefile-dep.patch
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'net-misc/unison/files/unison-2.48.4-Makefile-dep.patch')
-rw-r--r--net-misc/unison/files/unison-2.48.4-Makefile-dep.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch b/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch
new file mode 100644
index 000000000000..f65959dfb4ac
--- /dev/null
+++ b/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch
@@ -0,0 +1,20 @@
+Makefile.OCaml: fswatch.cmi depends on ubase/prefs.cmi.
+
+ The dependency is needed to compile unison
+ in parallel.
+
+Reference: https://github.com/bcpierce00/unison/pull/100
+
+diff --git a/Makefile.OCaml b/Makefile.OCaml
+index 21610ce..84fe7ad 100644
+--- a/Makefile.OCaml
++++ b/Makefile.OCaml
+@@ -426,6 +426,8 @@ win32rc/unison.res.lib: win32rc/unison.res
+ @echo "$(CAMLC): $< ---> $@"
+ $(CAMLC) $(CAMLFLAGS) -c $(CWD)/$<
+
++fswatch.cmi : ubase/prefs.cmi
++
+ %.cmo: %.ml
+ @echo "$(OCAMLC): $< ---> $@"
+ $(OCAMLC) $(CAMLFLAGS) -c $(CWD)/$<